summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-01-07 00:04:20 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-01-07 00:04:20 +0000
commit87d5641fe7a7b564a81d5a890571d3dd47f3cb51 (patch)
treef995426eeb03928ed3f0d9b11fdd3ff9e3cad324
parent8cd9199a7c8930882f46028347ac622f3c87edba (diff)
downloadfreebsd-ports-87d5641fe7a7b564a81d5a890571d3dd47f3cb51.zip
Add a patch from upstream fixing the parallel builds.
-rw-r--r--lang/perl5.18/files/patch-4d106cc5d8fd328d39b1db3c57572dd3dec915b534
1 files changed, 34 insertions, 0 deletions
diff --git a/lang/perl5.18/files/patch-4d106cc5d8fd328d39b1db3c57572dd3dec915b5 b/lang/perl5.18/files/patch-4d106cc5d8fd328d39b1db3c57572dd3dec915b5
new file mode 100644
index 000000000000..0c3deb2e3271
--- /dev/null
+++ b/lang/perl5.18/files/patch-4d106cc5d8fd328d39b1db3c57572dd3dec915b5
@@ -0,0 +1,34 @@
+From 4d106cc5d8fd328d39b1db3c57572dd3dec915b5 Mon Sep 17 00:00:00 2001
+From: Nicholas Clark <nick@ccl4.org>
+Date: Thu, 22 Aug 2013 11:48:29 +0200
+Subject: [PATCH] For SDBM_File, stop EU::MM from generating its default
+ subdirs rule.
+
+The default subdirs rule creates a race condition with the rule that
+Makefile.PL explicitly adds to generate libsdbm.a, which can cause parallel
+makes to fail.
+---
+ ext/SDBM_File/Makefile.PL | 6 ++++++
+ pod/perldelta.pod | 11 ++++++++++-
+ 2 files changed, 16 insertions(+), 1 deletion(-)
+
+diff --git ext/SDBM_File/Makefile.PL ext/SDBM_File/Makefile.PL
+index fa16a79..b96b80b 100644
+--- ext/SDBM_File/Makefile.PL
++++ ext/SDBM_File/Makefile.PL
+@@ -23,6 +23,12 @@ WriteMakefile(
+ PERL_MALLOC_OK => 1,
+ );
+
++# We don't want the default subdir rule, as it creates a race condition with the
++# rule we add below.
++sub MY::subdir_x {
++ return '';
++}
++
+ sub MY::postamble {
+ if ($^O =~ /MSWin32/ && !defined($ENV{SYSTEMROOT})) {
+ if ($Config{'make'} =~ /dmake/i) {
+--
+1.8.2.1
+