summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-11-28 13:06:27 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-11-28 13:06:27 +0000
commit7f90d246067ddfa8951c7f7c12c4710c84a8c997 (patch)
treea3a5630be8eae112c36ad4ec2fb1f188189fa5ae
parent24563d9480f634ff998cace41f384c9d3909df72 (diff)
downloadfreebsd-ports-7f90d246067ddfa8951c7f7c12c4710c84a8c997.zip
- Disable Jikes to avoid trouble with JDK 1.3
- Disable building extra documentation when not using JDK 1.5 as the Xalan processor used to tranform the XML source files seems to try and use X11 (which fails if built by superuser in a console) [1] NOTE: When using JDK 1.5 (java/jdk15) this error does not occur so it seems like we could find a fix for that. Otherwise I will probably convert the port to a binary one. Reported by: pointyhat [1]
-rw-r--r--textproc/xerces-j/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/textproc/xerces-j/Makefile b/textproc/xerces-j/Makefile
index e16ef205a655..35327f8817fd 100644
--- a/textproc/xerces-j/Makefile
+++ b/textproc/xerces-j/Makefile
@@ -20,6 +20,7 @@ CONFLICTS= xml4j-4.*
USE_JAVA= yes
JAVA_VERSION= 1.3+
USE_ANT= yes
+USE_JIKES= no
WRKSRC= ${WRKDIR}/xerces-${PORTVERSION:S/./_/g}
@@ -32,7 +33,10 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
ALL_TARGET= jars
.if !defined(NOPORTDOCS)
-ALL_TARGET+= javadocs docs
+ALL_TARGET+= javadocs
+.if ${JAVA_PORT_VERSION:C/[0-9]\.([0-9])\.[0-9]/\1/} == "5"
+ALL_TARGET+= docs
+.endif
PORTDOCS= *
.endif