summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-11-13 22:13:24 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-11-13 22:13:24 +0000
commit7e8050b16b32e3d21d3a5233a946eaa5120b5db2 (patch)
tree40de89588d283834a724d8036a4c3ffe380bc724
parente49ae2b3b5f5c32f28747cb944d196f0259106df (diff)
downloadfreebsd-ports-7e8050b16b32e3d21d3a5233a946eaa5120b5db2.zip
Chase PHP 5.4 expiration date
-rw-r--r--databases/mywwwatcher/Makefile3
-rw-r--r--databases/php5-creole/Makefile3
-rw-r--r--databases/php5-pdo_cassandra/Makefile2
-rw-r--r--databases/php5-propel/Makefile3
-rw-r--r--databases/php5-redis/Makefile3
-rw-r--r--databases/php5-tarantool/Makefile3
-rw-r--r--deskutils/fengoffice/Makefile3
-rw-r--r--devel/simpletest/Makefile3
-rw-r--r--graphics/php5-swfed/Makefile3
-rw-r--r--lang/php5-extensions/Makefile3
-rw-r--r--sysutils/loganalyzer/Makefile3
-rw-r--r--textproc/simplehtmldom/Makefile2
-rw-r--r--www/autoindex2/Makefile3
-rw-r--r--www/cakephp11/Makefile3
-rw-r--r--www/cakephp13/Makefile3
-rw-r--r--www/cakephp21/Makefile3
-rw-r--r--www/cakephp22/Makefile3
-rw-r--r--www/cakephp23/Makefile3
-rw-r--r--www/fluxcms/Makefile3
-rw-r--r--www/fusionpbx/Makefile3
-rw-r--r--www/jawstats/Makefile3
-rw-r--r--www/ojs2/Makefile3
-rw-r--r--www/pecl-zendopcache/Makefile3
-rw-r--r--www/webcalendar/Makefile3
24 files changed, 70 insertions, 0 deletions
diff --git a/databases/mywwwatcher/Makefile b/databases/mywwwatcher/Makefile
index 6376d7c8f245..75c0d211edda 100644
--- a/databases/mywwwatcher/Makefile
+++ b/databases/mywwwatcher/Makefile
@@ -11,6 +11,9 @@ DISTNAME= mywwwatcher-${PORTVERSION}
MAINTAINER= pm@kostax.cz
COMMENT= Simple web-based MySQL client + tools (dump, import, scheme, ...)
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
WRKSRC= ${WRKDIR}/mywwwatcher
WANT_PHP_WEB= yes
diff --git a/databases/php5-creole/Makefile b/databases/php5-creole/Makefile
index a2c74f8ed57c..bd8ac912f5b7 100644
--- a/databases/php5-creole/Makefile
+++ b/databases/php5-creole/Makefile
@@ -10,6 +10,9 @@ PKGNAMEPREFIX= php5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Database abstraction layer for PHP5
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_PHP= yes
PHP_DEFAULT= 5.4
NO_BUILD= yes
diff --git a/databases/php5-pdo_cassandra/Makefile b/databases/php5-pdo_cassandra/Makefile
index e96ea5bed06c..9d4e9321b4f3 100644
--- a/databases/php5-pdo_cassandra/Makefile
+++ b/databases/php5-pdo_cassandra/Makefile
@@ -13,6 +13,8 @@ COMMENT= PDO driver for Apache Cassandra
LICENSE= APACHE20
BROKEN= fails to compile
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
LIB_DEPENDS= libboost_iostreams.so:${PORTSDIR}/devel/boost-libs
diff --git a/databases/php5-propel/Makefile b/databases/php5-propel/Makefile
index 251198be31b7..c6ec7b3af608 100644
--- a/databases/php5-propel/Makefile
+++ b/databases/php5-propel/Makefile
@@ -10,6 +10,9 @@ PKGNAMEPREFIX= php5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Full-service object persistence and query toolkit for PHP
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_PHP= yes
PHP_DEFAULT= 5.4
WRKSRC= ${WRKDIR}
diff --git a/databases/php5-redis/Makefile b/databases/php5-redis/Makefile
index 68620a535d8b..55977b9fd7fb 100644
--- a/databases/php5-redis/Makefile
+++ b/databases/php5-redis/Makefile
@@ -11,6 +11,9 @@ COMMENT= PHP5-Extension for Redis
LICENSE= PHP301
+DEPRECATED= PHP 5.4 EOL reached, use databases/php55-redis or databases/php56-redis instead
+EXPIRATION_DATE= 2016-01-15
+
USE_PHP= session
USE_PHP_BUILD= yes
USE_PHPEXT= yes
diff --git a/databases/php5-tarantool/Makefile b/databases/php5-tarantool/Makefile
index c928bbd03802..24a7bc718107 100644
--- a/databases/php5-tarantool/Makefile
+++ b/databases/php5-tarantool/Makefile
@@ -9,6 +9,9 @@ PKGNAMEPREFIX= php5-
MAINTAINER= vg@FreeBSD.org
COMMENT= PECL PHP driver for Tarantool/Box
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_GITHUB= yes
USE_PHP= yes
USE_PHPEXT= yes
diff --git a/deskutils/fengoffice/Makefile b/deskutils/fengoffice/Makefile
index c074928ce4fc..3215a71389b1 100644
--- a/deskutils/fengoffice/Makefile
+++ b/deskutils/fengoffice/Makefile
@@ -11,6 +11,9 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= acm@FreeBSD.org
COMMENT= Open source web-based collaboration software
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USES= zip
NO_BUILD= yes
USE_PHP= mysql gd simplexml
diff --git a/devel/simpletest/Makefile b/devel/simpletest/Makefile
index 026444a1e3c6..aa15785a4a46 100644
--- a/devel/simpletest/Makefile
+++ b/devel/simpletest/Makefile
@@ -12,6 +12,9 @@ COMMENT= Unit testing, mock objects, and web testing framework for PHP
LICENSE= LGPL21
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_PHP= pcre
USE_PHP_BUILD= yes
DEFAULT_VERSIONS+= php=5
diff --git a/graphics/php5-swfed/Makefile b/graphics/php5-swfed/Makefile
index 09c19e25542c..2b55d9c89ca6 100644
--- a/graphics/php5-swfed/Makefile
+++ b/graphics/php5-swfed/Makefile
@@ -13,6 +13,9 @@ COMMENT= PHP extension to edit SWF file
LICENSE= PHP301
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
BUILD_DEPENDS= re2c:${PORTSDIR}/devel/re2c
LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib \
libpng.so:${PORTSDIR}/graphics/png
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index 0ddb9fb00bbf..7fa859b8ed7c 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -12,6 +12,9 @@ EXTRACT_ONLY= # none
MAINTAINER= ale@FreeBSD.org
COMMENT= "meta-port" to install PHP extensions
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_PHP= yes
PHP_DEFAULT= 5.4
IGNORE_WITH_PHP=53 55
diff --git a/sysutils/loganalyzer/Makefile b/sysutils/loganalyzer/Makefile
index 11615045ea4f..00b4c90d8d29 100644
--- a/sysutils/loganalyzer/Makefile
+++ b/sysutils/loganalyzer/Makefile
@@ -12,6 +12,9 @@ COMMENT= Web based Syslog browsing and analysis
LICENSE= GPLv3 # or later
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USES= cpe
CPE_VENDOR= adiscon
NO_BUILD= yes
diff --git a/textproc/simplehtmldom/Makefile b/textproc/simplehtmldom/Makefile
index 5cc4afb92d50..df014129923e 100644
--- a/textproc/simplehtmldom/Makefile
+++ b/textproc/simplehtmldom/Makefile
@@ -12,6 +12,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= PHP Simple HTML DOM Parser
BROKEN= unfetchable
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
USES= zip
NO_BUILD= yes
diff --git a/www/autoindex2/Makefile b/www/autoindex2/Makefile
index bf49a61e3fc9..636113bae9d4 100644
--- a/www/autoindex2/Makefile
+++ b/www/autoindex2/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME}%20PHP%20Script%202.x/${PORTNAME}%20P
MAINTAINER= ports@FreeBSD.org
COMMENT= PHP 5.x script that put a directory listing into a table
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= dos2unix
diff --git a/www/cakephp11/Makefile b/www/cakephp11/Makefile
index 634ad92413bd..70a16922f44a 100644
--- a/www/cakephp11/Makefile
+++ b/www/cakephp11/Makefile
@@ -13,6 +13,9 @@ DISTNAME= cake_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Framework for developing PHP web applications
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USES= tar:bzip2
USE_APACHE_RUN= 22+
diff --git a/www/cakephp13/Makefile b/www/cakephp13/Makefile
index d2896e9c7b36..a91799f13dca 100644
--- a/www/cakephp13/Makefile
+++ b/www/cakephp13/Makefile
@@ -11,6 +11,9 @@ COMMENT= Framework for developing PHP web applications
LICENSE= MIT
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_GITHUB= yes
PORTDOCS= README
diff --git a/www/cakephp21/Makefile b/www/cakephp21/Makefile
index 400277ccf171..83c67a03ed86 100644
--- a/www/cakephp21/Makefile
+++ b/www/cakephp21/Makefile
@@ -11,6 +11,9 @@ COMMENT= Framework for developing PHP web applications
LICENSE= MIT
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_GITHUB= yes
PORTDOCS= README
diff --git a/www/cakephp22/Makefile b/www/cakephp22/Makefile
index 77df9c90bfb9..b96ce151e476 100644
--- a/www/cakephp22/Makefile
+++ b/www/cakephp22/Makefile
@@ -11,6 +11,9 @@ COMMENT= Framework for developing PHP web applications
LICENSE= MIT
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_GITHUB= yes
PORTDOCS= README.md
diff --git a/www/cakephp23/Makefile b/www/cakephp23/Makefile
index e1c68e9dd744..f2df558ffc70 100644
--- a/www/cakephp23/Makefile
+++ b/www/cakephp23/Makefile
@@ -10,6 +10,9 @@ COMMENT= Framework for developing PHP web applications
LICENSE= MIT
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_GITHUB= yes
PORTDOCS= README.md
diff --git a/www/fluxcms/Makefile b/www/fluxcms/Makefile
index d56e5029ebc2..cf6f2f827bbd 100644
--- a/www/fluxcms/Makefile
+++ b/www/fluxcms/Makefile
@@ -11,6 +11,9 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-snapshot-20090308
MAINTAINER= beat@FreeBSD.org
COMMENT= Extensible and flexible CMS based on PHP 5 and XML/XSLT
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USES= shebangfix tar:tgz
SHEBANG_FILES= div/db/dbexport.sh \
div/db/dbexport40.sh \
diff --git a/www/fusionpbx/Makefile b/www/fusionpbx/Makefile
index 17645dc4580b..29fb13c6a4fa 100644
--- a/www/fusionpbx/Makefile
+++ b/www/fusionpbx/Makefile
@@ -13,6 +13,9 @@ COMMENT= PHP5 Graphical User Interface for FreeSwitch
LICENSE= MPL
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_odbc.so:${PORTSDIR}/databases/php${PHP_VER}-pdo_odbc
diff --git a/www/jawstats/Makefile b/www/jawstats/Makefile
index 3249262bf2d8..f4c872a550e1 100644
--- a/www/jawstats/Makefile
+++ b/www/jawstats/Makefile
@@ -9,6 +9,9 @@ MASTER_SITES= http://www.jawstats.com/src/
MAINTAINER= Alan@Wave2.org
COMMENT= JAWStats is a Free Web Site Statistics tool
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
RUN_DEPENDS= awstats>=6.8:${PORTSDIR}/www/awstats
NO_WRKSUBDIR= yes
diff --git a/www/ojs2/Makefile b/www/ojs2/Makefile
index 28d5ee827562..d7e820a530a3 100644
--- a/www/ojs2/Makefile
+++ b/www/ojs2/Makefile
@@ -13,6 +13,9 @@ DISTNAME= ojs-2.2.1
MAINTAINER= filiperocha@gmail.com
COMMENT= Journal management and publishing system
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
DIST_SUBDIR= ${PORTNAME}
NO_BUILD= yes
diff --git a/www/pecl-zendopcache/Makefile b/www/pecl-zendopcache/Makefile
index bc3b085127b6..b667e2e4f034 100644
--- a/www/pecl-zendopcache/Makefile
+++ b/www/pecl-zendopcache/Makefile
@@ -13,6 +13,9 @@ COMMENT= Opcode cacher and optimizer for PHP
LICENSE= PHP301
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
OPTIONS_DEFINE= DOCS
USES= tar:tgz
diff --git a/www/webcalendar/Makefile b/www/webcalendar/Makefile
index 89843a4c858c..133614d26a69 100644
--- a/www/webcalendar/Makefile
+++ b/www/webcalendar/Makefile
@@ -10,6 +10,9 @@ COMMENT= Web-based calendar application
LICENSE= GPLv2
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
PORTSCOUT= limit:^1\.2\. skipb:1
USE_PHP= pcre session
WANT_PHP_WEB= yes