summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2014-05-09 22:01:34 +0000
committerTim Bishop <tdb@FreeBSD.org>2014-05-09 22:01:34 +0000
commit78e2945cc4c8255ed7ff886cc84e8fe756270b6e (patch)
tree4690fc54a42d2f7e086641cc923f70c633b47fe0
parent256e6797b33ccd94220e054abc20a1136f04e856 (diff)
downloadfreebsd-ports-78e2945cc4c8255ed7ff886cc84e8fe756270b6e.zip
- Stage support
-rw-r--r--graphics/jalbum/Makefile7
-rw-r--r--irc/pircbot/Makefile28
-rw-r--r--irc/pircbot/files/pkg-message.in9
3 files changed, 21 insertions, 23 deletions
diff --git a/graphics/jalbum/Makefile b/graphics/jalbum/Makefile
index 703a51d0fba5..40ef51c546ae 100644
--- a/graphics/jalbum/Makefile
+++ b/graphics/jalbum/Makefile
@@ -23,10 +23,9 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
SUB_FILES= jalbum.sh
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${TAR} -cf - * | ${TAR} -xf - -C ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKDIR}/jalbum.sh ${PREFIX}/bin/jalbum
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${TAR} -cf - * | ${TAR} -xf - -C ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/jalbum.sh ${STAGEDIR}${PREFIX}/bin/jalbum
.include <bsd.port.mk>
diff --git a/irc/pircbot/Makefile b/irc/pircbot/Makefile
index f99147218f9a..6962dfab8a05 100644
--- a/irc/pircbot/Makefile
+++ b/irc/pircbot/Makefile
@@ -6,34 +6,24 @@ PORTVERSION= 1.5.0
PORTREVISION= 1
CATEGORIES= irc java
MASTER_SITES= http://www.jibble.org/files/ \
- ftp://ftp.i-scream.org/pub/www.jibble.org/files/ \
http://www.i-scream.org/pub/www.jibble.org/files/
MAINTAINER= tdb@FreeBSD.org
COMMENT= PircBot Java IRC Bot Framework
+LICENSE= GPLv2
+
USES= zip
NO_BUILD= yes
-
+NO_ARCH= yes
USE_JAVA= yes
-NO_STAGE= yes
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/pircbot.jar ${JAVAJARDIR}
-.ifndef(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${CP} -r ${WRKSRC}/javadocs/* ${DOCSDIR}/
-.endif
+SUB_FILES= pkg-message
+SUB_LIST= JAVAJARDIR=${JAVAJARDIR}
-post-install:
- @${ECHO_MSG} " ---------------------------------------------------------------"
- @${ECHO_MSG} " To use pircbot add ${JAVAJARDIR}/pircbot.jar to"
- @${ECHO_MSG} " your classpath. A short tutorial can be found here:"
- @${ECHO_MSG} " http://www.jibble.org/pircbot.php"
-.ifndef(NOPORTDOCS)
- @${ECHO_MSG} " pircbot javadoc documentation has also been installed in:"
- @${ECHO_MSG} " ${DOCSDIR}"
-.endif
- @${ECHO_MSG} " ---------------------------------------------------------------"
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/pircbot.jar ${STAGEDIR}${JAVAJARDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${CP} -r ${WRKSRC}/javadocs/* ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/irc/pircbot/files/pkg-message.in b/irc/pircbot/files/pkg-message.in
new file mode 100644
index 000000000000..e04808be2308
--- /dev/null
+++ b/irc/pircbot/files/pkg-message.in
@@ -0,0 +1,9 @@
+---------------------------------------------------------------
+To use pircbot add %%JAVAJARDIR%%/pircbot.jar to
+your classpath. A short tutorial can be found here:
+ http://www.jibble.org/pircbot.php
+
+If you have the DOCS option enabled the pircbot javadoc
+documentation will also have been installed in:
+ %%DOCSDIR%%
+---------------------------------------------------------------