summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2003-01-22 00:02:32 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2003-01-22 00:02:32 +0000
commit756984c917ddb06cf6b23d12a3431fce976a69be (patch)
tree284ed927486b2fd7117b049281c63a4e11324f86
parenta3fc91f72527d1738e826571948f425ec2502f78 (diff)
downloadfreebsd-ports-756984c917ddb06cf6b23d12a3431fce976a69be.zip
Respect ${CC} and ${CXX}; untangle ${CFLAGS}, ${CXXFLAGS} and ${CPPFLAGS}
which weren't quite right the first time around. No PORT_REVISION bump since the port is only a few hours old and not yet very useful.
-rw-r--r--devel/simgear/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 4c0d6933a145..cae0a3008b91 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -22,7 +22,8 @@ USE_X_PREFIX= yes
USE_MESA= yes
GNU_CONFIGURE= yes
# Force configure to look in /usr/local/{include,lib}
-CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV+= CC="${CC}" CFLAGS="${CFLAGS}" \
+ CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"