summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-03 17:01:00 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-03 17:01:00 +0000
commit746c73f783aa8b6f1da89831c488782bc02151bb (patch)
tree8497d90a6e3c423d755600abd7e978b460600edf
parentb42ce49dbebdbcdcea67bfc66686eb4bae668131 (diff)
downloadfreebsd-ports-746c73f783aa8b6f1da89831c488782bc02151bb.zip
Use BROKEN_FreeBSD_9 instead of IGNORE and version checks after r402877.
Not only does this simplify the Makefile, but BROKEN is the correct choice here ("BROKEN is reserved for ports that currently do not compile, install, deinstall, or run correctly. Use it for ports where the problem is believed to be temporary", says the Porter's Handbook). Suggested by marino@.
-rw-r--r--devel/thrift-cpp/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index 9e44208037c5..7a425249a104 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -44,13 +44,11 @@ CONFIGURE_ARGS+= \
--without-ruby \
--without-go
-.include <bsd.port.pre.mk>
-
# src/thrift/transport/TSSLSocket.cpp:147: error: 'TLSv1_1_method' was not declared in this scope
# src/thrift/transport/TSSLSocket.cpp:149: error: 'TLSv1_2_method' was not declared in this scope
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000015
-IGNORE= does not build with 9.x base OpenSSL
-.endif
+BROKEN_FreeBSD_9= does not build with 9.x base OpenSSL
+
+.include <bsd.port.pre.mk>
.if ${COMPILER_TYPE} == clang
USE_CXXSTD= c++11