summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-10-18 08:49:58 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-10-18 08:49:58 +0000
commit6da34690c1f8caa55878c589d7dfc557cb134229 (patch)
tree0000711aacd96ba822ebdf0103daed2823601e2c
parent68d7a67b19d50f07750afdbeffa1cf633207806c (diff)
downloadfreebsd-ports-6da34690c1f8caa55878c589d7dfc557cb134229.zip
sysutils/fusefs-ntfs: patch mkntfs to not check for block devices
PR: 197301 Submitted by: darius@dons.net.au
-rw-r--r--sysutils/fusefs-ntfs/Makefile2
-rw-r--r--sysutils/fusefs-ntfs/files/patch-ntfsprogs_mkntfs.c18
2 files changed, 19 insertions, 1 deletions
diff --git a/sysutils/fusefs-ntfs/Makefile b/sysutils/fusefs-ntfs/Makefile
index 3ca1ca0e7533..dec29d79cef9 100644
--- a/sysutils/fusefs-ntfs/Makefile
+++ b/sysutils/fusefs-ntfs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntfs
PORTVERSION= 2015.3.14
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://tuxera.com/opensource/
PKGNAMEPREFIX= fusefs-
diff --git a/sysutils/fusefs-ntfs/files/patch-ntfsprogs_mkntfs.c b/sysutils/fusefs-ntfs/files/patch-ntfsprogs_mkntfs.c
new file mode 100644
index 000000000000..4338563b5e04
--- /dev/null
+++ b/sysutils/fusefs-ntfs/files/patch-ntfsprogs_mkntfs.c
@@ -0,0 +1,18 @@
+--- ntfsprogs/mkntfs.c.orig 2015-03-14 14:10:12 UTC
++++ ntfsprogs/mkntfs.c
+@@ -3488,6 +3488,7 @@ static BOOL mkntfs_open_partition(ntfs_v
+ goto done;
+ }
+
++#ifndef __FreeBSD__
+ if (!S_ISBLK(sbuf.st_mode)) {
+ ntfs_log_error("%s is not a block device.\n", vol->dev->d_name);
+ if (!opts.force) {
+@@ -3526,6 +3527,7 @@ static BOOL mkntfs_open_partition(ntfs_v
+ ntfs_log_warning("mkntfs forced anyway.\n");
+ #endif
+ }
++#endif
+ /* Make sure the file system is not mounted. */
+ if (ntfs_check_if_mounted(vol->dev->d_name, &mnt_flags)) {
+ ntfs_log_perror("Failed to determine whether %s is mounted", vol->dev->d_name);