summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-30 10:52:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-30 10:52:04 +0000
commit6728c602ec6ab58f8a0755038e894cdb10acc791 (patch)
tree90ec838c6525b4dc3241b5408c15b71f7eb7f21c
parent44f5b91cc98bd520d51b537d5cf92190b3844f4d (diff)
downloadfreebsd-ports-6728c602ec6ab58f8a0755038e894cdb10acc791.zip
- Add LICENSE_FILE
- Pet portlint - Switch to @sample Approved by: portmgr blanket
-rw-r--r--net/exaddos/Makefile8
-rw-r--r--net/exaddos/pkg-plist4
2 files changed, 5 insertions, 7 deletions
diff --git a/net/exaddos/Makefile b/net/exaddos/Makefile
index d952fe9f0c27..0d55d81e1853 100644
--- a/net/exaddos/Makefile
+++ b/net/exaddos/Makefile
@@ -5,19 +5,19 @@ PORTNAME= exaddos
PORTVERSION= 0.4.0
CATEGORIES= net
MASTER_SITES= http://mirrors.rit.edu/zi/
-EXTRACT_SUFX= .tgz
MAINTAINER= zi@FreeBSD.org
COMMENT= Monitor your network for DDoS
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}snmp4-mibs>=0.1.4:${PORTSDIR}/net-mgmt/py-snmp4-mibs \
${PYTHON_PKGNAMEPREFIX}snmp4>=4.2.3:${PORTSDIR}/net-mgmt/py-snmp4
USE_GITHUB= yes
GH_ACCOUNT= Exa-Networks
-USES= python
+USES= python tar:tgz
SUB_FILES= pkg-message exaddos.sh exaddos.conf.sample
SUB_LIST= PYTHON_LIBDIR=${PYTHON_LIBDIR} PYTHON_CMD=${PYTHON_CMD} \
PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
@@ -30,11 +30,11 @@ do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}/lib
do-install:
- @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/sbin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/sbin/${PORTNAME}
@${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME} ${STAGEDIR}${ETCDIR}
@(cd ${WRKSRC}/lib && ${COPYTREE_SHARE} . ${STAGEDIR}${PYTHON_SITELIBDIR})
@(cd ${WRKSRC}/data/${PORTNAME} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/www/${PORTNAME})
- @${INSTALL_DATA} ${WRKDIR}/exaddos.conf.sample \
+ ${INSTALL_DATA} ${WRKDIR}/exaddos.conf.sample \
${STAGEDIR}${ETCDIR}
.include <bsd.port.mk>
diff --git a/net/exaddos/pkg-plist b/net/exaddos/pkg-plist
index fe1ceacba188..d8f49f8d8bd8 100644
--- a/net/exaddos/pkg-plist
+++ b/net/exaddos/pkg-plist
@@ -42,7 +42,5 @@ www/exaddos/html/index.html
www/exaddos/html/overview.html
www/exaddos/html/talkers.html
www/exaddos/html/talker.html
-@unexec if cmp -s %D/etc/exaddos/exaddos.conf %D/etc/exaddos/exaddos.conf.sample ; then rm -f %D/etc/exaddos/exaddos.conf ; fi
-etc/exaddos/exaddos.conf.sample
-@exec if [ ! -f %D/etc/exaddos/exaddos.conf ]; then cp -p %D/%F %B/exaddos.conf; fi
+@sample etc/exaddos/exaddos.conf.sample
@unexec if [ -d %D/%%ETCDIR%% ]; then echo "==> If you are permanently removing this port, you should do a ``rm -rf ${PKG_PREFIX}/etc/exaddos`` to remove any configuration files left."; fi