summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-03-27 14:32:31 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-03-27 14:32:31 +0000
commit6253b3d9f9fe76ec3e82bccbb5a39d2e7adc9e45 (patch)
tree08c3be990095aff30a2abc76d3eb9bb84f022a8c
parent6c8f034a434d214c5977a40ec34c554fcf232b98 (diff)
downloadfreebsd-ports-6253b3d9f9fe76ec3e82bccbb5a39d2e7adc9e45.zip
- Mark broken on 4.x
-rw-r--r--deskutils/lightning-thunderbird/Makefile4
-rw-r--r--deskutils/lightning/Makefile4
-rw-r--r--deskutils/sunbird/Makefile4
-rw-r--r--graphics/wxsvg/Makefile9
4 files changed, 19 insertions, 2 deletions
diff --git a/deskutils/lightning-thunderbird/Makefile b/deskutils/lightning-thunderbird/Makefile
index cd73cc99ca7a..aa7cad24a6d7 100644
--- a/deskutils/lightning-thunderbird/Makefile
+++ b/deskutils/lightning-thunderbird/Makefile
@@ -38,6 +38,10 @@ MOZ_MK_OPTIONS= MOZ_CO_PROJECT=calendar
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/mozilla/Makefile.common"
+.if ${OSVERSION} < 500000
+BROKEN= does not build
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
diff --git a/deskutils/lightning/Makefile b/deskutils/lightning/Makefile
index cd73cc99ca7a..aa7cad24a6d7 100644
--- a/deskutils/lightning/Makefile
+++ b/deskutils/lightning/Makefile
@@ -38,6 +38,10 @@ MOZ_MK_OPTIONS= MOZ_CO_PROJECT=calendar
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/mozilla/Makefile.common"
+.if ${OSVERSION} < 500000
+BROKEN= does not build
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
diff --git a/deskutils/sunbird/Makefile b/deskutils/sunbird/Makefile
index cd73cc99ca7a..aa7cad24a6d7 100644
--- a/deskutils/sunbird/Makefile
+++ b/deskutils/sunbird/Makefile
@@ -38,6 +38,10 @@ MOZ_MK_OPTIONS= MOZ_CO_PROJECT=calendar
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/mozilla/Makefile.common"
+.if ${OSVERSION} < 500000
+BROKEN= does not build
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
diff --git a/graphics/wxsvg/Makefile b/graphics/wxsvg/Makefile
index 1eb1bfc13e72..43e40e5e742e 100644
--- a/graphics/wxsvg/Makefile
+++ b/graphics/wxsvg/Makefile
@@ -19,12 +19,17 @@ RUN_DEPENDS= ${WX_CONFIG}:${PORTSDIR}/x11-toolkits/wxgtk26
INSTALLS_SHLIB= yes
WX_CONFIG= wxgtk2-2.6-config
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GNOME= libartlgpl2
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not build
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|' \
${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>