summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorR. Imura <imura@FreeBSD.org>2000-02-24 16:06:07 +0000
committerR. Imura <imura@FreeBSD.org>2000-02-24 16:06:07 +0000
commit56e3282db1976cd7b0634192ad4879a8b4668f43 (patch)
tree8ca45cd93343f0610830335c6d318fd0ae6aba30
parent6864e6fdeb394ca54d96e9e82dd2799a1aefe845 (diff)
downloadfreebsd-ports-56e3282db1976cd7b0634192ad4879a8b4668f43.zip
Add USE_QT=yes to respect $(CXX), and remove BROKEN=
-rw-r--r--devel/cervisia/Makefile16
-rw-r--r--graphics/killustrator/Makefile9
-rw-r--r--www/kdreamsite/Makefile9
3 files changed, 9 insertions, 25 deletions
diff --git a/devel/cervisia/Makefile b/devel/cervisia/Makefile
index 2c1d7836b1dc..568d1dc5e146 100644
--- a/devel/cervisia/Makefile
+++ b/devel/cervisia/Makefile
@@ -13,19 +13,13 @@ MAINTAINER= andrews@technologist.com
RUN_DEPENDS= kwm:${PORTSDIR}/x11/kdebase11
+USE_QT= yes
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${LOCALBASE} \
- --with-extra-includes="${LOCALBASE}/include" \
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-extra-includes="${LOCALBASE}/include" \
--with-extra-libraries="${LOCALBASE}/lib"
-CONFIGURE_ENV= prefix="${LOCALBASE}" KDEDIR="${LOCALBASE}"
+CONFIGURE_ENV= prefix="${PREFIX}" KDEDIR="${LOCALBASE}"
MAN1= cervisia.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400012
-BROKEN= "Requires NEWGCC-compiled kde libs"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/killustrator/Makefile b/graphics/killustrator/Makefile
index 34745b73c42e..a0c7f0976211 100644
--- a/graphics/killustrator/Makefile
+++ b/graphics/killustrator/Makefile
@@ -17,14 +17,9 @@ LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11 \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
RUN_DEPENDS= ${LOCALBASE}/bin/kdehelp:${PORTSDIR}/x11/kdebase11
+USE_QT= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400004
-BROKEN= "Requires NEWGCC-compiled KDE libs"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/kdreamsite/Makefile b/www/kdreamsite/Makefile
index d2d570175892..90b35de8a433 100644
--- a/www/kdreamsite/Makefile
+++ b/www/kdreamsite/Makefile
@@ -14,13 +14,8 @@ MAINTAINER= andrews@technologist.com
LIB_DEPENDS= kdeui.3:${PORTSDIR}/x11/kdelibs11/
+USE_QT= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400004
-BROKEN= "obsolete compiler"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>