summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2007-08-18 10:55:26 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2007-08-18 10:55:26 +0000
commit56731917e4d4c142af36716340f17018f8a85727 (patch)
tree754b2efcdcd8f3851a76e2d1ae535e301f5a565d
parente58923a1bbdc9a926c2bb0e5678ec88672a69eb0 (diff)
downloadfreebsd-ports-56731917e4d4c142af36716340f17018f8a85727.zip
Fix port to use openssl configurations provided by bsd.openssl.mk.
PR: 115532 Submitted by: Piet Delport <pjd@satori.za.net>
-rw-r--r--security/py-openssl/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/security/py-openssl/Makefile b/security/py-openssl/Makefile
index 26216fa9c670..5f4fdb942d7c 100644
--- a/security/py-openssl/Makefile
+++ b/security/py-openssl/Makefile
@@ -23,4 +23,9 @@ USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= pyOpenSSL
USE_OPENSSL= yes
+pre-configure:
+ @${ECHO_CMD} "[build_ext]" >> ${WRKSRC}/setup.cfg
+ @${ECHO_CMD} "include-dirs = ${OPENSSLINC}" >> ${WRKSRC}/setup.cfg
+ @${ECHO_CMD} "library-dirs = ${OPENSSLLIB}" >> ${WRKSRC}/setup.cfg
+
.include <bsd.port.mk>