summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-11-10 22:21:08 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-11-10 22:21:08 +0000
commit55e2d7a835681f340cbfbc4bde64d0078b68394b (patch)
treede3deeadbe46b0eb8268ed42358e8956525125e1
parentee42a3a263eebfcc9b9a24978cac11e6a593cc73 (diff)
downloadfreebsd-ports-55e2d7a835681f340cbfbc4bde64d0078b68394b.zip
audio/alsa-*: update to 1.1.0
Changes: http://www.alsa-project.org/main/index.php/Changes_v1.0.29_v1.1.0 ACC report: https://people.freebsd.org/~jbeich/compat_reports/alsa-lib/1.0.29_to_1.1.0/compat_report.html
-rw-r--r--audio/alsa-lib/Makefile4
-rw-r--r--audio/alsa-lib/distinfo4
-rw-r--r--audio/alsa-lib/files/linux/types.h8
-rw-r--r--audio/alsa-lib/files/patch-src_topology_parser.c10
-rw-r--r--audio/alsa-lib/pkg-plist6
-rw-r--r--audio/alsa-plugins/Makefile2
-rw-r--r--audio/alsa-plugins/distinfo4
-rw-r--r--audio/alsa-utils/Makefile10
-rw-r--r--audio/alsa-utils/distinfo4
-rw-r--r--audio/alsa-utils/pkg-plist3
10 files changed, 43 insertions, 12 deletions
diff --git a/audio/alsa-lib/Makefile b/audio/alsa-lib/Makefile
index 8d09e4cf299b..63ec52313555 100644
--- a/audio/alsa-lib/Makefile
+++ b/audio/alsa-lib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= alsa-lib
-PORTVERSION= 1.0.29
+PORTVERSION= 1.1.0
CATEGORIES= audio
MASTER_SITES= ALSA/lib \
GENTOO
@@ -33,6 +33,8 @@ post-patch: .SILENT
-e '/pythonlibs/s/--libs/--ldflags/' \
-e '/-D_GNU_SOURCE/d' \
-e '/lt_cv_dlopen/s/-ldl//g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e '/if.*_GNU_SOURCE/,/endif/d' \
+ ${WRKSRC}/include/config.h.in
${REINPLACE_CMD} '/LIBADD/s/-ldl//g' \
${WRKSRC}/modules/mixer/simple/Makefile.in
${REINPLACE_CMD} 's|/etc|${PREFIX}&|g' \
diff --git a/audio/alsa-lib/distinfo b/audio/alsa-lib/distinfo
index 81bb4bad69ae..9c08cc676bef 100644
--- a/audio/alsa-lib/distinfo
+++ b/audio/alsa-lib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (alsa-lib-1.0.29.tar.bz2) = 73043c35eb9636be0f4af6a240235c213f12a25feb1f04aeeac8cb7e30fcbdd0
-SIZE (alsa-lib-1.0.29.tar.bz2) = 905417
+SHA256 (alsa-lib-1.1.0.tar.bz2) = dfde65d11e82b68f82e562ab6228c1fb7c78854345d3c57e2c68a9dd3dae1f15
+SIZE (alsa-lib-1.1.0.tar.bz2) = 929874
diff --git a/audio/alsa-lib/files/linux/types.h b/audio/alsa-lib/files/linux/types.h
index 3fb397037f72..e6167fc3d1f2 100644
--- a/audio/alsa-lib/files/linux/types.h
+++ b/audio/alsa-lib/files/linux/types.h
@@ -1,11 +1,17 @@
#ifndef _LINUX_TYPES_H
#define _LINUX_TYPES_H
+#include <sys/types.h>
+
#define __bitwise
+#define __le16 __u16
+#define __le32 __u32
+#define __le64 __u64
-typedef int __kernel_pid_t;
+typedef pid_t __kernel_pid_t;
typedef off_t __kernel_off_t;
+typedef uint16_t __u16;
typedef uint32_t __u32;
typedef uint64_t __u64;
#endif /* _LINUX_TYPES_H */
diff --git a/audio/alsa-lib/files/patch-src_topology_parser.c b/audio/alsa-lib/files/patch-src_topology_parser.c
new file mode 100644
index 000000000000..30338b65d30f
--- /dev/null
+++ b/audio/alsa-lib/files/patch-src_topology_parser.c
@@ -0,0 +1,10 @@
+--- src/topology/parser.c.orig 2015-11-09 07:39:18 UTC
++++ src/topology/parser.c
+@@ -18,6 +18,7 @@
+
+ #include "list.h"
+ #include "tplg_local.h"
++#include <sys/stat.h>
+
+ /*
+ * Parse compound
diff --git a/audio/alsa-lib/pkg-plist b/audio/alsa-lib/pkg-plist
index fe824c9c4887..bcc41e7a8f00 100644
--- a/audio/alsa-lib/pkg-plist
+++ b/audio/alsa-lib/pkg-plist
@@ -25,14 +25,17 @@ include/alsa/seq.h
include/alsa/seq_event.h
include/alsa/seq_midi_event.h
include/alsa/seqmid.h
+include/alsa/sound/asoc.h
include/alsa/sound/asound_fm.h
include/alsa/sound/emu10k1.h
include/alsa/sound/hdsp.h
include/alsa/sound/hdspm.h
include/alsa/sound/sb16_csp.h
include/alsa/sound/sscape_ioctl.h
+include/alsa/sound/tlv.h
include/alsa/sound/type_compat.h
include/alsa/timer.h
+include/alsa/topology.h
include/alsa/use-case.h
include/alsa/version.h
include/sys/asoundlib.h
@@ -130,6 +133,7 @@ share/alsa/pcm/surround51.conf
share/alsa/pcm/surround71.conf
share/alsa/smixer.conf
share/alsa/sndo-mixer.alisp
+share/alsa/topology/broadwell/broadwell.conf
share/alsa/ucm/DAISY-I2S/DAISY-I2S.conf
share/alsa/ucm/DAISY-I2S/HiFi.conf
share/alsa/ucm/GoogleNyan/GoogleNyan.conf
@@ -158,5 +162,7 @@ share/alsa/ucm/SDP4430/hifiLP
share/alsa/ucm/SDP4430/record
share/alsa/ucm/SDP4430/voice
share/alsa/ucm/SDP4430/voiceCall
+share/alsa/ucm/broadwell-rt286/HiFi
+share/alsa/ucm/broadwell-rt286/broadwell-rt286.conf
share/alsa/ucm/tegraalc5632/tegraalc5632.conf
@sample etc/asound.conf.sample
diff --git a/audio/alsa-plugins/Makefile b/audio/alsa-plugins/Makefile
index 38128490ea7e..1e08d990be41 100644
--- a/audio/alsa-plugins/Makefile
+++ b/audio/alsa-plugins/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= alsa-plugins
-PORTVERSION= 1.0.29
+PORTVERSION= 1.1.0
CATEGORIES= audio
MASTER_SITES= ALSA/plugins \
GENTOO
diff --git a/audio/alsa-plugins/distinfo b/audio/alsa-plugins/distinfo
index 237754ccf563..eea425837295 100644
--- a/audio/alsa-plugins/distinfo
+++ b/audio/alsa-plugins/distinfo
@@ -1,2 +1,2 @@
-SHA256 (alsa-plugins-1.0.29.tar.bz2) = 325d85cac285f632b83e0191ae3f348bad03c1f007b937042f164abb81ea6532
-SIZE (alsa-plugins-1.0.29.tar.bz2) = 366077
+SHA256 (alsa-plugins-1.1.0.tar.bz2) = 3b83c329953bef99f5fe25ae04ec4a455fe6514939f3b45a5321966652b2c9ee
+SIZE (alsa-plugins-1.1.0.tar.bz2) = 366296
diff --git a/audio/alsa-utils/Makefile b/audio/alsa-utils/Makefile
index a5263ddc7de4..3b1c8c0dd089 100644
--- a/audio/alsa-utils/Makefile
+++ b/audio/alsa-utils/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= alsa-utils
-PORTVERSION= 1.0.29
+PORTVERSION= 1.1.0
CATEGORIES= audio
MASTER_SITES= ALSA/utils \
GENTOO
@@ -23,8 +23,12 @@ INSTALL_TARGET= install-strip
CPPFLAGS+= -I${.CURDIR}/../alsa-lib/files
OPTIONS_SUB= yes
-OPTIONS_DEFINE= MANPAGES NLS
-OPTIONS_DEFAULT=MANPAGES
+OPTIONS_DEFINE= BAT MANPAGES NLS
+OPTIONS_DEFAULT=BAT MANPAGES
+
+BAT_DESC= Basic Audio Tester support
+BAT_LIB_DEPENDS=libfftw3.so:${PORTSDIR}/math/fftw3
+BAT_CONFIGURE_ENABLE=bat
MANPAGES_BUILD_DEPENDS= xmlto:${PORTSDIR}/textproc/xmlto
MANPAGES_CONFIGURE_ENABLE=xmlto
diff --git a/audio/alsa-utils/distinfo b/audio/alsa-utils/distinfo
index d57eb063fea6..2816c2b01fd8 100644
--- a/audio/alsa-utils/distinfo
+++ b/audio/alsa-utils/distinfo
@@ -1,2 +1,2 @@
-SHA256 (alsa-utils-1.0.29.tar.bz2) = 5160058f3e14483ced5de919dd473f93932059454530a9b7ef97dcabd6833e9b
-SIZE (alsa-utils-1.0.29.tar.bz2) = 1154497
+SHA256 (alsa-utils-1.1.0.tar.bz2) = 3b1c3135b76e14532d3dd23fb15759ddd7daf9ffbc183f7a9a0a3a86374748f1
+SIZE (alsa-utils-1.1.0.tar.bz2) = 1181085
diff --git a/audio/alsa-utils/pkg-plist b/audio/alsa-utils/pkg-plist
index ef312608afa5..42eaff403f35 100644
--- a/audio/alsa-utils/pkg-plist
+++ b/audio/alsa-utils/pkg-plist
@@ -1,6 +1,7 @@
bin/aconnect
bin/alsaloop
bin/alsamixer
+bin/alsatplg
bin/alsaucm
bin/amidi
bin/amixer
@@ -10,6 +11,7 @@ bin/arecord
bin/arecordmidi
bin/aseqdump
bin/aseqnet
+%%BAT%%bin/bat
bin/iecset
bin/speaker-test
lib/udev/90-alsa-restore.rules
@@ -26,6 +28,7 @@ man/man1/arecord.1.gz
man/man1/arecordmidi.1.gz
man/man1/aseqdump.1.gz
man/man1/aseqnet.1.gz
+%%BAT%%man/man1/bat.1.gz
man/man1/iecset.1.gz
man/man1/speaker-test.1.gz
%%MANPAGES%%man/man7/alsactl_init.7.gz