summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBarbara Guida <bar@FreeBSD.org>2014-06-07 12:02:17 +0000
committerBarbara Guida <bar@FreeBSD.org>2014-06-07 12:02:17 +0000
commit512624352b5192f687861c11497d932944462473 (patch)
tree34460504e4afbed9e335b6992ea1af49aa4e04d4
parent4e9b9a9078fc01026047768d94463c87a5a051c5 (diff)
downloadfreebsd-ports-512624352b5192f687861c11497d932944462473.zip
Fix startup script for NVIDIA_GL setting a working __GL_ExtensionStringVersion.
-rw-r--r--games/linux-rtcw/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/linux-rtcw/Makefile b/games/linux-rtcw/Makefile
index 8b6614730a6d..0fa1130bbb20 100644
--- a/games/linux-rtcw/Makefile
+++ b/games/linux-rtcw/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rtcw
DISTVERSION= 1.41b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= ${MASTER_SITE_IDSOFTWARE}
MASTER_SITE_SUBDIR= wolf/linux
@@ -33,6 +33,7 @@ NVIDIA_GL_DESC= Use GL driver from nvidia-driver
.if ${PORT_OPTIONS:MNVIDIA_GL}
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+NVIDIA_GL_EXTVER= '__GL_ExtensionStringVersion=18999 '
.else
USE_LINUX_APPS+= dri
.endif
@@ -45,7 +46,7 @@ do-build:
.for f in ${WRAPPERS}
(${ECHO_CMD} "#!${SH}"; ${ECHO_CMD}; \
${ECHO_CMD} "cd ${DATADIR} || exit 1"; \
- ${ECHO_CMD} 'exec ./${f} "$$@"') > ${WRKDIR}/${f}
+ ${ECHO_CMD} '${NVIDIA_GL_EXTVER}exec ./${f} "$$@"') > ${WRKDIR}/${f}
.endfor
do-install: