summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-09-30 05:52:30 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-09-30 05:52:30 +0000
commit4b48adab5f20a77ddd1b7bf253353ec66b13a9b2 (patch)
treee689cd57cbe55aa63deeb2dcff1d6eab8ce59c24
parent78efa1039556c2932093b7d59614defb1ed8006c (diff)
downloadfreebsd-ports-4b48adab5f20a77ddd1b7bf253353ec66b13a9b2.zip
BROKEN on 5.x: Does not compile
Approved by: portmgr (self)
-rw-r--r--chinese/BBMan/Makefile8
-rw-r--r--graphics/yafaray/Makefile4
-rw-r--r--graphics/yafray/Makefile4
3 files changed, 15 insertions, 1 deletions
diff --git a/chinese/BBMan/Makefile b/chinese/BBMan/Makefile
index b32995746bd7..47a57f7ee25e 100644
--- a/chinese/BBMan/Makefile
+++ b/chinese/BBMan/Makefile
@@ -22,10 +22,16 @@ USE_ZIP= yes
WRKSRC= ${WRKDIR}/BBMan
USE_X_PREFIX= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-build:
cd ${WRKSRC} && g++ main.cpp `wxgtk2-2.4-config --libs --cxxflags` -I${LOCALBASE}/include -O2 -o BBMan
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/BBMan ${PREFIX}/bin/BBMan
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/yafaray/Makefile b/graphics/yafaray/Makefile
index bbe6fdc8ca49..6a8a47ae9ee9 100644
--- a/graphics/yafaray/Makefile
+++ b/graphics/yafaray/Makefile
@@ -39,6 +39,10 @@ pre-everything::
BROKEN= "Does not compile (bad C++ code)"
.endif
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | \
${XARGS} ${REINPLACE_CMD} -E -e \
diff --git a/graphics/yafray/Makefile b/graphics/yafray/Makefile
index bbe6fdc8ca49..6a8a47ae9ee9 100644
--- a/graphics/yafray/Makefile
+++ b/graphics/yafray/Makefile
@@ -39,6 +39,10 @@ pre-everything::
BROKEN= "Does not compile (bad C++ code)"
.endif
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | \
${XARGS} ${REINPLACE_CMD} -E -e \