summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2007-09-02 05:54:44 +0000
committerGreg Lewis <glewis@FreeBSD.org>2007-09-02 05:54:44 +0000
commit483a3a3beb8bf337244d6be627d554ef94739d61 (patch)
tree7c7159fab64edb44fd154d8dab7bf7ce4b2c032a
parent282e3928bbc944154a584ed80b27ea1915549e80 (diff)
downloadfreebsd-ports-483a3a3beb8bf337244d6be627d554ef94739d61.zip
. Fix another problem with exec() by using the same static initialisation
block that Linux and Solaris use. This was already fixed in the repo but I'd neglected to commit the fix to the port and it was independently submitted as noted below. Submitted by: Michiel Boland <michiel@boland.org>
-rw-r--r--java/jdk16/Makefile2
-rw-r--r--java/jdk16/files/patch-j2se-lang-UNIXProcess.java.bsd15
2 files changed, 16 insertions, 1 deletions
diff --git a/java/jdk16/Makefile b/java/jdk16/Makefile
index c0798697995e..df99dbef7b0a 100644
--- a/java/jdk16/Makefile
+++ b/java/jdk16/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jdk
PORTVERSION= ${JDK_VERSION}.${JDK_UPDATE_VERSION}p${JDK_PATCHSET_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= java devel
MASTER_SITES= # http://download.java.net/jdk6/
# http://www.eyesbeyond.com/freebsddom/java/jdk16.html
diff --git a/java/jdk16/files/patch-j2se-lang-UNIXProcess.java.bsd b/java/jdk16/files/patch-j2se-lang-UNIXProcess.java.bsd
new file mode 100644
index 000000000000..5a0ac49d560b
--- /dev/null
+++ b/java/jdk16/files/patch-j2se-lang-UNIXProcess.java.bsd
@@ -0,0 +1,15 @@
+$FreeBSD$
+
+--- ../../j2se/src/solaris/classes/java/lang/UNIXProcess.java.bsd 28 Apr 2007 18:05:52 -0000 1.1
++++ ../../j2se/src/solaris/classes/java/lang/UNIXProcess.java.bsd 28 Aug 2007 06:42:17 -0000 1.2
+@@ -195,4 +195,10 @@
+ }
+ }
+
++ /* This routine initializes JNI field offsets for the class */
++ private static native void initIDs();
++
++ static {
++ initIDs();
++ }
+ }