summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-02-09 01:54:56 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-02-09 01:54:56 +0000
commit447562319ea054e8d99cfa98a9c92d158ba89161 (patch)
tree8633de88c533dcd86574662fdc7e585a3c8f534c
parent870c7b2ae31a7cbc2ed521a96a5a72b4607253f5 (diff)
downloadfreebsd-ports-447562319ea054e8d99cfa98a9c92d158ba89161.zip
Allow staging USE_RUBY_SETUP ports.
They must be built with the proper prefix, but at install phase they should be passed --prefix=STAGEDIR. It will already install to the previously used PREFIX so this will end up installing into ${STAGEDIR}${PREFIX} With hat: ruby
-rw-r--r--Mk/bsd.ruby.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 04137852cca2..4db277052966 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -555,7 +555,11 @@ do-install: ruby-setup-install
ruby-setup-install:
@${ECHO_MSG} "===> Running ${RUBY_SETUP} to install"
@cd ${INSTALL_WRKSRC}; \
+. if defined(NO_STAGE)
${SETENV} ${MAKE_ENV} ${RUBY} ${RUBY_FLAGS} ${RUBY_SETUP} install
+. else
+ ${SETENV} ${MAKE_ENV} ${RUBY} ${RUBY_FLAGS} ${RUBY_SETUP} install --prefix=${STAGEDIR}
+. endif
.endif
.if defined(USE_LIBRUBY)