summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-08-22 15:59:34 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-08-22 15:59:34 +0000
commit403cdd37e8a0f6329be71453ba82c34315201a77 (patch)
tree64795d1324bff1e3c0e89f8599e51e2aeecc5984
parente0b3b91c8598db86f7b980c406607fb2455a3bb1 (diff)
downloadfreebsd-ports-403cdd37e8a0f6329be71453ba82c34315201a77.zip
Add devel/compiz-bcop, a code generator that provides an easy way to handle
plugin options by generating parts of the plugin code directly from the xml metadata file. It is used for most of the Compiz Fusion plugins. PR: ports/115704 Submitted by: Robert Noland <rnoland@2hip.net>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/compiz-bcop/Makefile35
-rw-r--r--devel/compiz-bcop/distinfo3
-rw-r--r--devel/compiz-bcop/pkg-descr5
-rw-r--r--devel/compiz-bcop/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bd222213b220..22a0ff048e5d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -176,6 +176,7 @@
SUBDIR += cogito
SUBDIR += colorer
SUBDIR += commoncpp
+ SUBDIR += compiz-bcop
SUBDIR += configgen
SUBDIR += cons
SUBDIR += cons-test
diff --git a/devel/compiz-bcop/Makefile b/devel/compiz-bcop/Makefile
new file mode 100644
index 000000000000..2cbc2e3012da
--- /dev/null
+++ b/devel/compiz-bcop/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: compiz-bcop
+# Date created: 2007-08-15
+# Whom: Robert Noland <rnoland@2hip.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= compiz-bcop
+PORTVERSION= 0.5.2
+#PORTREVISION= 0
+CATEGORIES= devel x11-wm
+MASTER_SITES= http://releases.compiz-fusion.org/${PORTVERSION}/
+
+MAINTAINER= rnoland@2hip.net
+COMMENT= Code generator for Compiz Fusion Plugins
+
+# This annoys me...
+RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+USE_GNOME= pkgconfig libxslt
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' \
+ ${WRKSRC}/src/bcop.in
+ @${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/compiz-bcop/distinfo b/devel/compiz-bcop/distinfo
new file mode 100644
index 000000000000..f7180f1a0892
--- /dev/null
+++ b/devel/compiz-bcop/distinfo
@@ -0,0 +1,3 @@
+MD5 (compiz-bcop-0.5.2.tar.bz2) = b31e8e2ad3de2e5a23628bb0eacc11dc
+SHA256 (compiz-bcop-0.5.2.tar.bz2) = b53ecab9a54c0436be03b9ef32a4bd82b8c584ca399a4db1cc550c0947b31691
+SIZE (compiz-bcop-0.5.2.tar.bz2) = 68297
diff --git a/devel/compiz-bcop/pkg-descr b/devel/compiz-bcop/pkg-descr
new file mode 100644
index 000000000000..d2520aef07e0
--- /dev/null
+++ b/devel/compiz-bcop/pkg-descr
@@ -0,0 +1,5 @@
+BCOP is a code generator that provides an easy way to handle
+plugin options by generating parts of the plugin code directly from the xml
+metadata file. It is used for most of the Compiz Fusion plugins.
+
+WWW: http://forum.compiz-fusion.org/
diff --git a/devel/compiz-bcop/pkg-plist b/devel/compiz-bcop/pkg-plist
new file mode 100644
index 000000000000..92c91e64b571
--- /dev/null
+++ b/devel/compiz-bcop/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+bin/bcop
+libdata/pkgconfig/bcop.pc
+share/bcop/bcop.xslt
+@dirrmtry share/bcop