summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-02-06 19:49:22 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-02-06 19:49:22 +0000
commit3e3b09223ae4334fc02ff1ad2bf520e5edac9885 (patch)
tree2fb080fa50dc9ff85182d776b4c9a3595b401b06
parent61ac4cb94b5449cdfcd80d5ab3f8747726b79b7b (diff)
downloadfreebsd-ports-3e3b09223ae4334fc02ff1ad2bf520e5edac9885.zip
- Stage support
- New LIB_DEPENDS syntax - Uses libtool gmake
-rw-r--r--net/xmlrpc-epi/Makefile17
-rw-r--r--net/xmlrpc-epi/pkg-plist1
2 files changed, 8 insertions, 10 deletions
diff --git a/net/xmlrpc-epi/Makefile b/net/xmlrpc-epi/Makefile
index 01308a263a8c..8398b4c0b391 100644
--- a/net/xmlrpc-epi/Makefile
+++ b/net/xmlrpc-epi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xmlrpc-epi
PORTVERSION= 0.54.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-base/${PORTVERSION}/
@@ -11,15 +12,14 @@ COMMENT= General purpose implementation of the xmlrpc specification in C
LICENSE= MIT
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
-USES= iconv
-USE_AUTOTOOLS= libtool
+USES= gmake iconv libtool
USE_BZIP2= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform="s|^|xre-|"
PORTDOCS= AUTHORS ChangeLog NEWS README
@@ -29,14 +29,11 @@ METHODS= TestNormal TestFault TestStruct TestArray TestBoolean \
CONFLICTS= xmlrpc-c-0.* xmlrpc-c-devel-[0-9]*
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
regression-test:
.for tm in ${METHODS}
diff --git a/net/xmlrpc-epi/pkg-plist b/net/xmlrpc-epi/pkg-plist
index 3566f74f6ff2..34c96003cdd2 100644
--- a/net/xmlrpc-epi/pkg-plist
+++ b/net/xmlrpc-epi/pkg-plist
@@ -17,3 +17,4 @@ lib/libxmlrpc-epi.a
lib/libxmlrpc-epi.la
lib/libxmlrpc-epi.so
lib/libxmlrpc-epi.so.0
+lib/libxmlrpc-epi.so.0.0.3