summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-31 02:28:23 +0000
committerWill Andrews <will@FreeBSD.org>2001-03-31 02:28:23 +0000
commit3d63d2f5debf9444463b63bc3135c69657579934 (patch)
tree78b2f3cd234ded52d9a1739a2595939dc1121dc0
parent7e8d10a55eefa3eb5dc57b8276215cb5f0b14ee7 (diff)
downloadfreebsd-ports-3d63d2f5debf9444463b63bc3135c69657579934.zip
Add jumpgate 0.6, a TCP connection forwarder.
PR: 25935 Submitted by: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
-rw-r--r--net/Makefile1
-rw-r--r--net/jumpgate/Makefile24
-rw-r--r--net/jumpgate/distinfo1
-rw-r--r--net/jumpgate/pkg-comment1
-rw-r--r--net/jumpgate/pkg-descr8
-rw-r--r--net/jumpgate/pkg-plist1
6 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 77f5237f03e4..f7ce825db484 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -135,6 +135,7 @@
SUBDIR += isc-dhcp3
SUBDIR += isic
SUBDIR += jabber
+ SUBDIR += jumpgate
SUBDIR += jwhois
SUBDIR += kdenetwork2
SUBDIR += kdetelnet
diff --git a/net/jumpgate/Makefile b/net/jumpgate/Makefile
new file mode 100644
index 000000000000..1de7c0bcca57
--- /dev/null
+++ b/net/jumpgate/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: jumpgate
+# Date created: 20 March 2001
+# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jumpgate
+PORTVERSION= 0.6
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= leeym@cae.ce.ntu.edu.tw
+
+ALL_TARGET= generic
+
+pre-build:
+ ${PERL} -pi.orig -e "s@gcc@${CC}@g; s@-Wall@-Wall ${CFLAGS}@g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/jumpgate/distinfo b/net/jumpgate/distinfo
new file mode 100644
index 000000000000..b56c9764194d
--- /dev/null
+++ b/net/jumpgate/distinfo
@@ -0,0 +1 @@
+MD5 (jumpgate-0.6.tar.gz) = a5faf5ebebbf8b9e20137c53663be8b7
diff --git a/net/jumpgate/pkg-comment b/net/jumpgate/pkg-comment
new file mode 100644
index 000000000000..22d07fb36bc4
--- /dev/null
+++ b/net/jumpgate/pkg-comment
@@ -0,0 +1 @@
+TCP connection forwarder
diff --git a/net/jumpgate/pkg-descr b/net/jumpgate/pkg-descr
new file mode 100644
index 000000000000..4263ea8b0ba8
--- /dev/null
+++ b/net/jumpgate/pkg-descr
@@ -0,0 +1,8 @@
+Jumpgate is a TCP connection forwarder that provides many enhancements and
+improvements over the existing programs that do the same thing. Only
+tested on OpenBSD, but should run without problems on any Unix-like
+system. If you furtherly improve it, please send me the diffs. As always,
+published under a BSD style license, see the included LICENSE file.
+
+--
+Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
diff --git a/net/jumpgate/pkg-plist b/net/jumpgate/pkg-plist
new file mode 100644
index 000000000000..b1ac4788bc74
--- /dev/null
+++ b/net/jumpgate/pkg-plist
@@ -0,0 +1 @@
+bin/jumpgate