summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-06 12:15:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-06 12:15:22 +0000
commit36337b43f4b5b9b9e5031c8db65528655e699336 (patch)
tree7637017a5834dbc575f4b1085eae19b61162bf13
parent2ad0f678f568b028de082ea3ef6b2d8079b1d667 (diff)
downloadfreebsd-ports-36337b43f4b5b9b9e5031c8db65528655e699336.zip
- Stage support
-rw-r--r--editors/xcoral/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/editors/xcoral/Makefile b/editors/xcoral/Makefile
index 0da6c9a1f91d..bfb6a16c528f 100644
--- a/editors/xcoral/Makefile
+++ b/editors/xcoral/Makefile
@@ -17,7 +17,6 @@ MAKE_JOBS_UNSAFE= yes
PLIST_SUB= VERSION="${PORTVERSION}"
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's| regex\.c | |g ; \
s| -g | |g' ${WRKSRC}/Makefile.in
@@ -25,12 +24,10 @@ post-patch:
's|"regex\.h"|<gnu/regex.h>|g' ${WRKSRC}/bm_search.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xcoral ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/SmacLib/* ${DATADIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Doc/* ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/xcoral ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/SmacLib/* ${STAGEDIR}${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Doc/* ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>