summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-08-20 17:55:31 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-08-20 17:55:31 +0000
commit29bb71911508ea5271f790f3f630787a201d2468 (patch)
tree83cf71fd83248707280527b7fb52fb88786b2482
parentb44cb941e773542690b523c455e611c96e909115 (diff)
downloadfreebsd-ports-29bb71911508ea5271f790f3f630787a201d2468.zip
Chaosreader is a perl script that parses snoop or tcpdump logs
and extracts sessions for a number of different appplications: ssh, telnet, smtp, irc, ftp, etc. The data are formatted into an html file and can be used to replay some sessions. Sshkeydata is a perl script that attempts to recreate ssh sessions extracted by chaosreader by estimating what commands may have been typed. Both scripts are installed in ${PREFIX}/bin WWW: http://sourceforge.net/projects/chaosreader PR: ports/115125 Submitted by: pauls
-rw-r--r--security/Makefile1
-rw-r--r--security/chaosreader/Makefile36
-rw-r--r--security/chaosreader/distinfo6
-rw-r--r--security/chaosreader/pkg-descr12
4 files changed, 55 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 92189e15d5af..c51f1473db02 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -60,6 +60,7 @@
SUBDIR += ccrypt
SUBDIR += cfs
SUBDIR += cfv
+ SUBDIR += chaosreader
SUBDIR += checkpassword
SUBDIR += checkpassword-pam
SUBDIR += chkrootkit
diff --git a/security/chaosreader/Makefile b/security/chaosreader/Makefile
new file mode 100644
index 000000000000..8103adde63f8
--- /dev/null
+++ b/security/chaosreader/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: chaosreader
+# Date created: 1 Aug 2007
+# Whom: pauls
+#
+# $FreeBSD$
+#
+
+PORTNAME= chaosreader
+PORTVERSION= 0.94
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= chaosreader
+DISTFILES= ${PORTNAME}${PORTVERSION} sshkeydata0.20
+EXTRACT_ONLY=
+
+MAINTAINER= pauls@utdallas.edu
+COMMENT= A tool to extract data from tcpdump logs
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+PLIST_FILES= bin/${PORTNAME} bin/sshkeydata
+
+post-extract:
+ ${CP} ${DISTDIR}/${PORTNAME}${PORTVERSION} ${WRKDIR}/${PORTNAME}
+ ${CP} ${DISTDIR}/sshkeydata0.20 ${WRKDIR}/sshkeydata
+
+post-patch:
+ ${REINPLACE_CMD} s:/usr/bin/perl:${PERL}: \
+ ${WRKDIR}/${PORTNAME} ${WRKDIR}/sshkeydata
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/sshkeydata ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/chaosreader/distinfo b/security/chaosreader/distinfo
new file mode 100644
index 000000000000..3ffc6cdcbe63
--- /dev/null
+++ b/security/chaosreader/distinfo
@@ -0,0 +1,6 @@
+MD5 (chaosreader0.94) = ef307a4aa11964dc2558248847219ae9
+SHA256 (chaosreader0.94) = e84e2044aec3371ea5505d7d7db2c746d62ee1d24c970b90775e25c3625ab982
+SIZE (chaosreader0.94) = 185986
+MD5 (sshkeydata0.20) = 0fc49c757b879a4636e2b68983538449
+SHA256 (sshkeydata0.20) = 324b6b7b4110dbfbb9ca93309853b651d290018b4d0d3fe68ae3078fca27e36d
+SIZE (sshkeydata0.20) = 11341
diff --git a/security/chaosreader/pkg-descr b/security/chaosreader/pkg-descr
new file mode 100644
index 000000000000..5653a1660e79
--- /dev/null
+++ b/security/chaosreader/pkg-descr
@@ -0,0 +1,12 @@
+Chaosreader is a perl script that parses snoop or tcpdump logs
+and extracts sessions for a number of different appplications:
+ssh, telnet, smtp, irc, ftp, etc. The data are formatted into
+an html file and can be used to replay some sessions.
+
+Sshkeydata is a perl script that attempts to recreate ssh
+sessions extracted by chaosreader by estimating what commands
+may have been typed.
+
+Both scripts are installed in ${PREFIX}/bin
+
+WWW: http://sourceforge.net/projects/chaosreader