summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2023-08-10 22:37:38 -0500
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2023-08-10 22:37:38 -0500
commit2717f14ed7645a468d22a05bf7000ee12b239f7c (patch)
treeb7cabee47393fb33fde120da8a9280165f244687
parent5cf2775606b95b2a551f6b55fd8a0283e81504f7 (diff)
downloadfreebsd-ports-2717f14ed7645a468d22a05bf7000ee12b239f7c.zip
math/octave: Update to 8.3.0.
-rw-r--r--Mk/Uses/octave.mk2
-rw-r--r--math/octave/Makefile1
-rw-r--r--math/octave/distinfo6
-rw-r--r--math/octave/files/patch-liboctave_numeric_sparse-qr.cc92
-rw-r--r--math/octave/pkg-plist6
5 files changed, 7 insertions, 100 deletions
diff --git a/Mk/Uses/octave.mk b/Mk/Uses/octave.mk
index 15cf67e4879a..a45c0286a77d 100644
--- a/Mk/Uses/octave.mk
+++ b/Mk/Uses/octave.mk
@@ -22,7 +22,7 @@ IGNORE= Incorrect 'USES+= octave:${octave_ARGS}' usage: argument [${arg}] is not
. endif
. endfor
-OCTAVE_VERSION= 8.2.0
+OCTAVE_VERSION= 8.3.0
. if empty(octave_ARGS:Menv)
BUILD_DEPENDS+= octave:math/octave
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 2710d16b9025..6a8f4d69eb57 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -1,6 +1,5 @@
PORTNAME= octave
PORTVERSION= ${OCTAVE_VERSION}
-PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= GNU
diff --git a/math/octave/distinfo b/math/octave/distinfo
index 3b96dde27391..5a4824d45fe3 100644
--- a/math/octave/distinfo
+++ b/math/octave/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1681536019
-SHA256 (octave-8.2.0.tar.xz) = b7b9d6e5004ff039450cfedd2a59ddbe2a3c22296df927a8af994182eb2670de
-SIZE (octave-8.2.0.tar.xz) = 26970452
+TIMESTAMP = 1691723084
+SHA256 (octave-8.3.0.tar.xz) = 919c9494f02ca435e1e3474990e6df8ddef9acbc9c90565e08d40b8f50445ba9
+SIZE (octave-8.3.0.tar.xz) = 26970776
diff --git a/math/octave/files/patch-liboctave_numeric_sparse-qr.cc b/math/octave/files/patch-liboctave_numeric_sparse-qr.cc
deleted file mode 100644
index 0ea48c7d50eb..000000000000
--- a/math/octave/files/patch-liboctave_numeric_sparse-qr.cc
+++ /dev/null
@@ -1,92 +0,0 @@
---- liboctave/numeric/sparse-qr.cc.orig 2023-04-13 16:43:35 UTC
-+++ liboctave/numeric/sparse-qr.cc
-@@ -1786,7 +1786,7 @@ sparse_qr<SparseComplexMatrix>::sparse_qr_rep::Q (bool
- OCTAVE_LOCAL_BUFFER (cs_complex_t, bvec, nr);
-
- for (octave_idx_type i = 0; i < nr; i++)
-- bvec[i] = cs_complex_t (0.0, 0.0);
-+ bvec[i] = (cs_complex_t)0;
-
- OCTAVE_LOCAL_BUFFER (Complex, buf, S->m2);
-
-@@ -1813,7 +1813,7 @@ sparse_qr<SparseComplexMatrix>::sparse_qr_rep::Q (bool
- for (octave_idx_type i = 0; i < nr; i++)
- vec[i+idx] = buf[i];
-
-- bvec[j] = cs_complex_t (0.0, 0.0);
-+ bvec[j] = (cs_complex_t)0;
- }
- }
-
-@@ -2073,7 +2073,7 @@ sparse_qr<SparseComplexMatrix>::sparse_qr_rep::tall_so
- Xx[j] = b.xelem (j, i);
-
- for (octave_idx_type j = nr; j < S->m2; j++)
-- buf[j] = cs_complex_t (0.0, 0.0);
-+ buf[j] = (cs_complex_t)0;
-
- CXSPARSE_ZNAME (_ipvec) (S->pinv,
- reinterpret_cast<cs_complex_t *>(Xx),
-@@ -2143,7 +2143,7 @@ sparse_qr<SparseComplexMatrix>::sparse_qr_rep::wide_so
- Xx[j] = b.xelem (j, i);
-
- for (octave_idx_type j = nr; j < nbuf; j++)
-- buf[j] = cs_complex_t (0.0, 0.0);
-+ buf[j] = (cs_complex_t)0;
-
- CXSPARSE_ZNAME (_pvec) (S->q, reinterpret_cast<cs_complex_t *> (Xx),
- buf, nr);
-@@ -2206,7 +2206,7 @@ sparse_qr<SparseComplexMatrix>::sparse_qr_rep::tall_so
- Xx[j] = b.xelem (j, i);
-
- for (octave_idx_type j = nr; j < S->m2; j++)
-- buf[j] = cs_complex_t (0.0, 0.0);
-+ buf[j] = (cs_complex_t)0;
-
- CXSPARSE_ZNAME (_ipvec) (S->pinv,
- reinterpret_cast<cs_complex_t *> (Xx),
-@@ -2304,7 +2304,7 @@ sparse_qr<SparseComplexMatrix>::sparse_qr_rep::wide_so
- Xx[j] = b.xelem (j, i);
-
- for (octave_idx_type j = nr; j < nbuf; j++)
-- buf[j] = cs_complex_t (0.0, 0.0);
-+ buf[j] = (cs_complex_t)0;
-
- CXSPARSE_ZNAME (_pvec) (S->q,
- reinterpret_cast<cs_complex_t *> (Xx),
-@@ -2392,7 +2392,7 @@ sparse_qr<SparseComplexMatrix>::sparse_qr_rep::tall_so
- octave_quit ();
-
- for (octave_idx_type j = nr; j < S->m2; j++)
-- buf[j] = cs_complex_t (0.0, 0.0);
-+ buf[j] = (cs_complex_t)0;
-
- CXSPARSE_ZNAME (_ipvec) (S->pinv, bvec + bidx, buf, nr);
-
-@@ -2460,7 +2460,7 @@ sparse_qr<SparseComplexMatrix>::sparse_qr_rep::wide_so
- octave_quit ();
-
- for (octave_idx_type j = nr; j < nbuf; j++)
-- buf[j] = cs_complex_t (0.0, 0.0);
-+ buf[j] = (cs_complex_t)0;
-
- CXSPARSE_ZNAME (_pvec) (S->q, bvec + bidx, buf, nr);
- CXSPARSE_ZNAME (_utsolve) (N->U, buf);
-@@ -2522,7 +2522,7 @@ sparse_qr<SparseComplexMatrix>::sparse_qr_rep::tall_so
- Xx[j] = b.xelem (j, i);
-
- for (octave_idx_type j = nr; j < S->m2; j++)
-- buf[j] = cs_complex_t (0.0, 0.0);
-+ buf[j] = (cs_complex_t)0;
-
- CXSPARSE_ZNAME (_ipvec) (S->pinv,
- reinterpret_cast<cs_complex_t *> (Xx),
-@@ -2620,7 +2620,7 @@ sparse_qr<SparseComplexMatrix>::sparse_qr_rep::wide_so
- Xx[j] = b.xelem (j, i);
-
- for (octave_idx_type j = nr; j < nbuf; j++)
-- buf[j] = cs_complex_t (0.0, 0.0);
-+ buf[j] = (cs_complex_t)0;
-
- CXSPARSE_ZNAME (_pvec) (S->q, reinterpret_cast<cs_complex_t *>(Xx),
- buf, nr);
diff --git a/math/octave/pkg-plist b/math/octave/pkg-plist
index 603756dfda8c..2c5a986545d0 100644
--- a/math/octave/pkg-plist
+++ b/math/octave/pkg-plist
@@ -767,13 +767,13 @@ include/octave-%%OCTAVE_VERSION%%/octave/xnorm.h
include/octave-%%OCTAVE_VERSION%%/octave/xpow.h
lib/octave/%%OCTAVE_VERSION%%/liboctave.so
lib/octave/%%OCTAVE_VERSION%%/liboctave.so.10
-lib/octave/%%OCTAVE_VERSION%%/liboctave.so.10.0.0
+lib/octave/%%OCTAVE_VERSION%%/liboctave.so.10.0.1
lib/octave/%%OCTAVE_VERSION%%/liboctgui.so
lib/octave/%%OCTAVE_VERSION%%/liboctgui.so.9
-lib/octave/%%OCTAVE_VERSION%%/liboctgui.so.9.0.0
+lib/octave/%%OCTAVE_VERSION%%/liboctgui.so.9.0.1
lib/octave/%%OCTAVE_VERSION%%/liboctinterp.so
lib/octave/%%OCTAVE_VERSION%%/liboctinterp.so.11
-lib/octave/%%OCTAVE_VERSION%%/liboctinterp.so.11.0.0
+lib/octave/%%OCTAVE_VERSION%%/liboctinterp.so.11.0.1
lib/octave/%%OCTAVE_VERSION%%/oct/%%GNU_HOST%%/PKG_ADD
lib/octave/%%OCTAVE_VERSION%%/oct/%%GNU_HOST%%/__delaunayn__.oct
lib/octave/%%OCTAVE_VERSION%%/oct/%%GNU_HOST%%/__fltk_uigetfile__.oct