summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-02 08:36:13 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-02 08:36:13 +0000
commit2104d78f03a72908cfc078f5fb2382298ad8bafa (patch)
treece5e7c77b4c1b3c8017a294712d99622770059bc
parente5596d782833c4bdbdd060bdd800b81a785a3b1b (diff)
downloadfreebsd-ports-2104d78f03a72908cfc078f5fb2382298ad8bafa.zip
- Make sshit catch this type of error login:
PAM: authentication error for lissyara from 192.168.254.193 PR: ports/114194 Submitted by: Alex Keda <admin at lissyara.su> Approved by: maintainer via irc
-rw-r--r--security/sshit/Makefile1
-rw-r--r--security/sshit/files/patch-sshit.diff11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/sshit/Makefile b/security/sshit/Makefile
index a06263f3a049..7616c0b65b6a 100644
--- a/security/sshit/Makefile
+++ b/security/sshit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sshit
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://anp.ath.cx/sshit/ \
${MASTER_SITE_LOCAL}
diff --git a/security/sshit/files/patch-sshit.diff b/security/sshit/files/patch-sshit.diff
new file mode 100644
index 000000000000..9cdce15bccd6
--- /dev/null
+++ b/security/sshit/files/patch-sshit.diff
@@ -0,0 +1,11 @@
+--- sshit.orig Sun Jul 1 22:13:45 2007
++++ sshit Sun Jul 1 22:14:46 2007
+@@ -317,7 +317,7 @@
+
+ while (<>) {
+ chomp;
+- if (/(failed|Invalid user) .*from (\d+\.\d+\.\d+\.\d+|[\da-fA-F:]+)/i ) { # IPv4 & IPv6
++ if (/(failed|error|Invalid user) .*from (\d+\.\d+\.\d+\.\d+|[\da-fA-F:]+)/i ) { # IPv4 & IPv6
+ $ip = $2;
+ if ($list{$ip}{name}) {
+ if ($list{$ip}{n} >= $MAX_COUNT) {