summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2015-10-19 12:50:32 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2015-10-19 12:50:32 +0000
commit2032d653606a9e8cbc033afa8d96ed32e11383ca (patch)
tree1ea3997154d32d365910901344ef1a9d0bef3122
parent881df5d72204bd9d0cf621763e33b9d6f9b9010f (diff)
downloadfreebsd-ports-2032d653606a9e8cbc033afa8d96ed32e11383ca.zip
(1) Fix slave ports
(2) Improve apache configuration sample PR: 203838 Submitted by: Olli Hauer <ohauer@FreeBSD.org>
-rw-r--r--devel/subversion18/Makefile6
-rw-r--r--devel/subversion18/Makefile.common4
-rw-r--r--devel/subversion18/files/220_subversion.conf.sample.in18
3 files changed, 21 insertions, 7 deletions
diff --git a/devel/subversion18/Makefile b/devel/subversion18/Makefile
index bbb3df03694c..8c1b4280c077 100644
--- a/devel/subversion18/Makefile
+++ b/devel/subversion18/Makefile
@@ -1,7 +1,7 @@
# Created by: rooneg@electricjellyfish.net
# $FreeBSD$
-PORTREVISION= 2
+PORTREVISION= 3
MAINTAINER= lev@FreeBSD.org
COMMENT= Version control system
@@ -169,9 +169,9 @@ post-install: ${MKREPOS_TARGET}
(cd ${WRKSRC}/tools.examples && ${TAR} --exclude '*.in' -cf - * | ${TAR} -C ${STAGEDIR}${DATADIR} -xof - )
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.if ${PORT_OPTIONS:MSVNSERVE_WRAPPER}
+
+post-install-SVNSERVE_WRAPPER-on:
@${INSTALL_SCRIPT} ${FILESDIR}/svnserve.wrapper ${STAGEDIR}${PREFIX}/bin/svnserve.sample
-.endif
# ===============================================================================
repository: _mkrepos
diff --git a/devel/subversion18/Makefile.common b/devel/subversion18/Makefile.common
index 645b860cf140..e547180e8a14 100644
--- a/devel/subversion18/Makefile.common
+++ b/devel/subversion18/Makefile.common
@@ -31,8 +31,8 @@ CONFIGURE_ARGS+= --without-swig \
.if defined(SVN_BUILD_ADDONS)
CONFLICTS_BUILD+= ${PORTNAME}-1.[^8].[0-9]*
-LIB_DEPENDS+= libsvn_client-1.so:${PORTSDIR}/devel/subversion
-OPTIONS_NAME= devel_subversion
+LIB_DEPENDS+= libsvn_client-1.so:${PORTSDIR}/devel/subversion18
+OPTIONS_NAME= devel_subversion18
.endif
# ===============================================================
diff --git a/devel/subversion18/files/220_subversion.conf.sample.in b/devel/subversion18/files/220_subversion.conf.sample.in
index 184cc13fec59..59c38f78dfb3 100644
--- a/devel/subversion18/files/220_subversion.conf.sample.in
+++ b/devel/subversion18/files/220_subversion.conf.sample.in
@@ -39,6 +39,15 @@
## KeepAlive on
## MaxKeepAliveRequests 1000
##
+## # http://subversion.apache.org/docs/release-notes/1.7.html#server-performance-tuning
+## # Calculate your own values!
+## # For mod_dav_svn, a 1GB cache configuration with maximum data coverage looks like this
+## <IfModule dav_svn_module>
+## SVNInMemoryCacheSize 1048576
+## SVNCacheFullTexts on
+## SVNCacheTextDeltas on
+## </IfModule>
+##
## Multiple Repos with Digest auth:
## - AuthName is an arbitrary name that you choose for the authentication
## domain. Most browsers display this name in the dialog box when prompting
@@ -46,9 +55,14 @@
## - AuthType specifies the type of authentication to use.
## - AuthUserFile specifies the location of the password file to use.
##
-##<IfModule dav_module>
+##<IfModule dav_svn_module>
##<Location /svn/>
-## # Enable Subversion
+## <ifModule mime_module>
+## RemoveEncoding .gz .tgz .Z
+## RemoveType .gz .tgz .Z
+## </ifModule>
+##
+#### # Enable Subversion
## DAV svn
##
## # Directory containing all repository for this path