summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-09-01 21:58:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-09-01 21:58:02 +0000
commit12d4d5398e7f444c534f1d7798e761696263d4f9 (patch)
tree43d99f42609afc5cba77485ff8696d0295be6353
parent89f586de982c22c4445cf57efbd9c13ce3022ff2 (diff)
downloadfreebsd-ports-12d4d5398e7f444c534f1d7798e761696263d4f9.zip
- Fix build with Apache 2.2: explicitly depend on pcre library
PR: ports/110645 Approved by: maintainer timeout (1 month)
-rw-r--r--www/mod_security2/Makefile8
-rw-r--r--www/mod_security21/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/www/mod_security2/Makefile b/www/mod_security2/Makefile
index 5bee20024478..2e592b83033b 100644
--- a/www/mod_security2/Makefile
+++ b/www/mod_security2/Makefile
@@ -60,6 +60,12 @@ USE_GNOME= libxml2
REINPLACE_ARGS= -i ""
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} == 22
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '\
s|SecRuleEngine On|SecRuleEngine DetectionOnly|; \
@@ -79,4 +85,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mod_security21/Makefile b/www/mod_security21/Makefile
index 5bee20024478..2e592b83033b 100644
--- a/www/mod_security21/Makefile
+++ b/www/mod_security21/Makefile
@@ -60,6 +60,12 @@ USE_GNOME= libxml2
REINPLACE_ARGS= -i ""
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} == 22
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '\
s|SecRuleEngine On|SecRuleEngine DetectionOnly|; \
@@ -79,4 +85,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>