summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-27 15:17:26 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-27 15:17:26 +0000
commit0a0bcfbc545bf7321d1d9baa89b628a221cdd3eb (patch)
treef3f7b9324d9c9494194594bd3988fec89115e7cc
parent014bb2aecc0a535d90bcdbfd11ca59bb56916c4d (diff)
downloadfreebsd-ports-0a0bcfbc545bf7321d1d9baa89b628a221cdd3eb.zip
Import a bunch of iconv fixes.
Submitted by: marino Approved by: portmgr (bapt, implicit)
-rw-r--r--chinese/fcitx/Makefile3
-rw-r--r--chinese/sunpinyin/Makefile3
-rw-r--r--games/caph/Makefile3
-rw-r--r--graphics/djvulibre/Makefile1
-rw-r--r--math/gnuplot/Makefile2
-rw-r--r--x11-wm/awesome/Makefile1
-rw-r--r--x11-wm/awesome2/Makefile1
-rw-r--r--x11-wm/blackbox/Makefile1
-rw-r--r--x11-wm/i3/Makefile1
9 files changed, 13 insertions, 3 deletions
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index 5289a18dee10..99a548a5db04 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -33,8 +33,9 @@ USE_XZ= yes
USE_GNOME= pango intltool libxml2 introspection
USE_XORG= x11 xext xkbfile
USE_LDCONFIG= yes
-USES= cmake gettext pathfix pkgconfig
+USES= cmake gettext iconv pathfix pkgconfig
INSTALLS_ICONS= yes
+DFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
OPTIONS_DEFINE= GTK2 GTK3 QT4 OPENCC TPUNC
OPTIONS_DEFAULT=GTK2
diff --git a/chinese/sunpinyin/Makefile b/chinese/sunpinyin/Makefile
index 64e0c1c13f90..752088ffeb8c 100644
--- a/chinese/sunpinyin/Makefile
+++ b/chinese/sunpinyin/Makefile
@@ -23,7 +23,8 @@ USE_XZ= yes
USE_SCONS= yes
SCONS_ARGS+= --prefix=${PREFIX} --libdatadir=${PREFIX}/share
USE_LDCONFIG= yes
-USES= gmake pkgconfig
+USES= gmake iconv pkgconfig
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
NO_STAGE= yes
post-patch:
diff --git a/games/caph/Makefile b/games/caph/Makefile
index 2e6e04ea6a4a..1d1038068039 100644
--- a/games/caph/Makefile
+++ b/games/caph/Makefile
@@ -15,6 +15,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/doc/caph/COPYING
+USES= iconv
USE_BZIP2= yes
USE_SDL= sdl
USE_GL= gl
@@ -42,7 +43,7 @@ CFLAGS+= -O3 -ffast-math
do-build:
cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} -o caph -I../include *.c \
- `${SDL_CONFIG} --libs --cflags` -D_OPENGL -lGL -lpng
+ `${SDL_CONFIG} --libs --cflags` -D_OPENGL -lGL -lpng ${ICONV_LIB}
post-patch:
@${REINPLACE_CMD} -e 's|../share/caph|${DATADIR}|' ${BUILD_WRKSRC}/caph.c
diff --git a/graphics/djvulibre/Makefile b/graphics/djvulibre/Makefile
index 0743abde5091..e30f0c9dda87 100644
--- a/graphics/djvulibre/Makefile
+++ b/graphics/djvulibre/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
USES= pathfix iconv
GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ENV= JPEG_CFLAGS="-I${LOCALBASE}/include" \
JPEG_LIBS="-L${LOCALBASE}/lib -ljpeg" \
TIFF_CFLAGS="-I${LOCALBASE}/include" \
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 17bb36b8fe4b..7f97ecfc96cd 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -9,7 +9,9 @@ MASTER_SITES= SF
MAINTAINER= glewis@FreeBSD.org
COMMENT= Command-line driven graphing utility
+USES= iconv
GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS+=--with-lasergnu \
--with-readline=gnu \
--without-linux-vga \
diff --git a/x11-wm/awesome/Makefile b/x11-wm/awesome/Makefile
index 2d13c6a34878..9d70efc2981f 100644
--- a/x11-wm/awesome/Makefile
+++ b/x11-wm/awesome/Makefile
@@ -41,6 +41,7 @@ USE_GNOME= glib20 pango
USE_LUA= 5.1+
USE_XORG= pixman x11 xau xcb xdmcp xext xft xinerama xrandr xrender \
xproto
+LDFLAGS+= ${ICONV_LIB}
MAN1= awesome.1 \
awesome-client.1
diff --git a/x11-wm/awesome2/Makefile b/x11-wm/awesome2/Makefile
index eae453221d88..a74855481fa8 100644
--- a/x11-wm/awesome2/Makefile
+++ b/x11-wm/awesome2/Makefile
@@ -22,6 +22,7 @@ GNU_CONFIGURE= yes
USE_EFL= imlib2
USE_GNOME= pango
USE_XORG= x11 xft xext xinerama xt xrandr xproto
+LDFLAGS+= -lX11 -lXext ${ICONV_LIB}
MAN1= awesome2.1 \
awesome2-client.1 \
diff --git a/x11-wm/blackbox/Makefile b/x11-wm/blackbox/Makefile
index 7cc82d09066c..154fe7e7dfec 100644
--- a/x11-wm/blackbox/Makefile
+++ b/x11-wm/blackbox/Makefile
@@ -15,6 +15,7 @@ LICENSE= MIT
GNU_CONFIGURE= yes
USES= pathfix pkgconfig iconv
USE_XORG= x11 xft
+LDFLAGS+= ${ICONV_LIB}
MAN1= bsetbg.1 bsetroot.1
PORTDOCS= README.bbtools README.bsetbg
diff --git a/x11-wm/i3/Makefile b/x11-wm/i3/Makefile
index ccc081707526..b9f7257604fe 100644
--- a/x11-wm/i3/Makefile
+++ b/x11-wm/i3/Makefile
@@ -29,6 +29,7 @@ USE_XORG= x11 xcb xcursor
USES= pkgconfig iconv gmake perl5
USE_BZIP2= yes
USE_PERL5= run
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
MAKE_JOBS_UNSAFE= yes
post-patch: