summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-03-02 21:18:43 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-03-02 21:18:43 +0000
commit09bd67d4f4aff85a009b3f87dc054515d60abeb4 (patch)
tree0aace971b73a9af4c5c8c78c41f3050bf875c874
parent4d2c0028d08e66e31439825845d165fb631ef46a (diff)
downloadfreebsd-ports-09bd67d4f4aff85a009b3f87dc054515d60abeb4.zip
Set USES=mpi.
-rw-r--r--math/blacs/Makefile4
-rw-r--r--math/blacs/files/pkg-message.in4
-rw-r--r--math/sprng/Makefile8
-rw-r--r--math/sprng/pkg-plist20
-rw-r--r--science/code_saturne/Makefile12
5 files changed, 24 insertions, 24 deletions
diff --git a/math/blacs/Makefile b/math/blacs/Makefile
index b37e1996b425..d0c84e03782c 100644
--- a/math/blacs/Makefile
+++ b/math/blacs/Makefile
@@ -29,10 +29,10 @@ OPTIONS_DEFAULT= DOCS MPICH
DOCS_DISTFILES= blacs_install.ps f77blacsqref.ps lawn94.ps \
cblacsqref.ps mpi_prop.ps mpiblacs_issues.ps
-OPENMPI_LIB_DEPENDS= libmpi.so:net/openmpi
+OPENMPI_USES= mpi:openmpi
OPENMPI_EXTRA_PATCHES= ${FILESDIR}/Bmake.inc-openmpi.diff
-MPICH_LIB_DEPENDS= libmpi.so:net/mpich
+MPICH_USES= mpi:mpich
MPICH_EXTRA_PATCHES= ${FILESDIR}/Bmake.inc-mpich.diff
.include <bsd.port.pre.mk>
diff --git a/math/blacs/files/pkg-message.in b/math/blacs/files/pkg-message.in
index 3bee27f7e15c..0fce9bb971c6 100644
--- a/math/blacs/files/pkg-message.in
+++ b/math/blacs/files/pkg-message.in
@@ -11,8 +11,8 @@
Or, if you're using OpenMPI:
% cd %%PREFIX%%/share/BLACS/TESTING
- % LD_LIBRARY_PATH=%%LOCALBASE%%/mpi/openmpi3/lib/ export LD_LIBRARY_PATH
- % PATH=$PATH:%%LOCALBASE%%/mpi/openmpi3/bin/ export PATH
+ % LD_LIBRARY_PATH=%%LOCALBASE%%/mpi/openmpi/lib/ export LD_LIBRARY_PATH
+ % PATH=$PATH:%%LOCALBASE%%/mpi/openmpi/bin/ export PATH
% mpirun -np 4 ./xCbtest_MPI-FreeBSD
% mpirun -np 4 ./xFbtest_MPI-FreeBSD
diff --git a/math/sprng/Makefile b/math/sprng/Makefile
index 0dca86e57a61..853e1e174b81 100644
--- a/math/sprng/Makefile
+++ b/math/sprng/Makefile
@@ -27,11 +27,11 @@ TEST_TARGET= check
PORTEXAMPLES= *
-OPTIONS_DEFINE= EXAMPLES MPI
-OPTIONS_DEFAULT= EXAMPLES MPI
+OPTIONS_DEFINE= EXAMPLES MPICH
+OPTIONS_DEFAULT= EXAMPLES MPICH
OPTIONS_SUB= yes
-MPI_LIB_DEPENDS= libmpi.so:net/mpich
-MPI_CONFIGURE_WITH= mpi
+MPICH_USES= mpi:mpich
+MPICH_CONFIGURE_WITH= mpi
ASCII_TEXTS= checkcmrg checklcg checklcg64 checklfg checkmlfg checkpmlcg \
checksprng timecmrg timelcg timelcg64 timelfg timemlfg timepmlcg\
diff --git a/math/sprng/pkg-plist b/math/sprng/pkg-plist
index efcdfa21ec72..68060d31f76a 100644
--- a/math/sprng/pkg-plist
+++ b/math/sprng/pkg-plist
@@ -1,4 +1,4 @@
-%%MPI%%bin/2streams_mpi.tmp
+%%MPICH%%bin/2streams_mpi.tmp
bin/FIPS_140_2.tmp
bin/alphabit.tmp
bin/bigCrush.tmp
@@ -30,26 +30,26 @@ bin/convertf.tmp
bin/coupon.tmp
bin/crush.tmp
bin/equidist.tmp
-%%MPI%%bin/fsprng-simple_mpi.tmp
-%%MPI%%bin/fsprng_mpi.tmp
+%%MPICH%%bin/fsprng-simple_mpi.tmp
+%%MPICH%%bin/fsprng_mpi.tmp
bin/gap.tmp
bin/libsprng.a
bin/maxt.tmp
-%%MPI%%bin/message-simple_mpi.tmp
-%%MPI%%bin/message_mpi.tmp
+%%MPICH%%bin/message-simple_mpi.tmp
+%%MPICH%%bin/message_mpi.tmp
bin/metropolis.tmp
bin/perm.tmp
bin/pi-simple.tmp
-%%MPI%%bin/pi-simple_mpi.tmp
+%%MPICH%%bin/pi-simple_mpi.tmp
bin/pif-simple.tmp
bin/poker.tmp
bin/rabbit.tmp
bin/random_walk.tmp
bin/runs.tmp
bin/seed-simple.tmp
-%%MPI%%bin/seed-simple_mpi.tmp
+%%MPICH%%bin/seed-simple_mpi.tmp
bin/seed.tmp
-%%MPI%%bin/seed_mpi.tmp
+%%MPICH%%bin/seed_mpi.tmp
bin/seedf-simple.tmp
bin/seedf.tmp
bin/serial.tmp
@@ -59,9 +59,9 @@ bin/smallCrush.tmp
bin/spawn.tmp
bin/spawnf.tmp
bin/sprng-simple.tmp
-%%MPI%%bin/sprng-simple_mpi.tmp
+%%MPICH%%bin/sprng-simple_mpi.tmp
bin/sprng.tmp
-%%MPI%%bin/sprng_mpi.tmp
+%%MPICH%%bin/sprng_mpi.tmp
bin/sprngf-simple.tmp
bin/sprngf.tmp
bin/subroutinef.tmp
diff --git a/science/code_saturne/Makefile b/science/code_saturne/Makefile
index 06749e0247f0..5439c10675b8 100644
--- a/science/code_saturne/Makefile
+++ b/science/code_saturne/Makefile
@@ -43,8 +43,8 @@ BINARY_ALIAS= python=${PYTHON_CMD} \
pyrcc5=pyrcc5-${PYTHON_VER} \
pyuic5=pyuic5-${PYTHON_VER}
-OPTIONS_DEFINE= DOCS EXAMPLES BATCH BLAS MPI SCOTCH
-OPTIONS_DEFAULT= BATCH BLAS MPI SCOTCH METIS
+OPTIONS_DEFINE= DOCS EXAMPLES BATCH BLAS MPICH SCOTCH
+OPTIONS_DEFAULT= BATCH BLAS MPICH SCOTCH METIS
OPTIONS_RADIO= METIS
OPTIONS_RADIO_METIS= METIS PARMETIS
BLAS_DESC= Support of OpenBLAS
@@ -53,10 +53,10 @@ BLAS_CONFIGURE_ON= --with-blas=yes --with-blas-lib=${LOCALBASE}/lib --with-blas-
BLAS_LIB_DEPENDS= libopenblas.so:math/openblas
BATCH_DESC= Use Torque to submit batches
BATCH_RUN_DEPENDS= pbs-config:sysutils/torque
-MPI_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
-MPI_LIB_DEPENDS= libmpi.so:net/mpich
-MPI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
-MPI_CONFIGURE_WITH= mpi
+MPICH_USES= mpi
+MPICH_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
+MPICH_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
+MPICH_CONFIGURE_WITH= mpi
METIS_DESC= Support of METIS
METIS_LIB_DEPENDS= libmetis.so:math/metis
METIS_CONFIGURE_ON= --with-metis-include="${LOCALBASE}/include"