summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-04 14:43:36 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-04 14:43:36 +0000
commit051885751b717e40319b461d3342705b79e1f9e4 (patch)
tree2adebcf9ffec013413f1177bcd1953c3e955e030
parentee7ece749df666d765232dc4c334562231d69cc4 (diff)
downloadfreebsd-ports-051885751b717e40319b461d3342705b79e1f9e4.zip
Python OpenSSL wrapper. For modern cryptography with ECC, AES, HMAC,
Blowfish, ... WWW: https://github.com/yann2192/pyelliptic PR: 201390 Submitted by: yuri@rawbw.com
-rw-r--r--security/Makefile1
-rw-r--r--security/py-pyelliptic/Makefile24
-rw-r--r--security/py-pyelliptic/distinfo2
-rw-r--r--security/py-pyelliptic/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 420491c615d0..60e8c4c74dbe 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -848,6 +848,7 @@
SUBDIR += py-pycrypto
SUBDIR += py-pycryptopp
SUBDIR += py-pydeep
+ SUBDIR += py-pyelliptic
SUBDIR += py-pylibacl
SUBDIR += py-pyme
SUBDIR += py-pyptlib
diff --git a/security/py-pyelliptic/Makefile b/security/py-pyelliptic/Makefile
new file mode 100644
index 000000000000..a0b9821c53ad
--- /dev/null
+++ b/security/py-pyelliptic/Makefile
@@ -0,0 +1,24 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pyelliptic
+PORTVERSION= 1.5.6
+CATEGORIES= security python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Python OpenSSL wrapper
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>=0:${PORTSDIR}/security/py-openssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= yann2192
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-pyelliptic/distinfo b/security/py-pyelliptic/distinfo
new file mode 100644
index 000000000000..3b0ced7e5c5a
--- /dev/null
+++ b/security/py-pyelliptic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (yann2192-pyelliptic-1.5.6_GH0.tar.gz) = 00ef8c16c4b542dcb8bd6cf7b59f823d4c3f32ac6de46a8d97dfd0176c14f8c4
+SIZE (yann2192-pyelliptic-1.5.6_GH0.tar.gz) = 11567
diff --git a/security/py-pyelliptic/pkg-descr b/security/py-pyelliptic/pkg-descr
new file mode 100644
index 000000000000..c0f3ffd787ff
--- /dev/null
+++ b/security/py-pyelliptic/pkg-descr
@@ -0,0 +1,4 @@
+Python OpenSSL wrapper. For modern cryptography with ECC, AES, HMAC,
+Blowfish, ...
+
+WWW: https://github.com/yann2192/pyelliptic