summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-09-10 13:28:51 +0000
committerSteve Wills <swills@FreeBSD.org>2014-09-10 13:28:51 +0000
commit021a5b1f66bc8f09e6058f7a525e0261107bab8e (patch)
treeb9bb000b2caf8954954b90665d2caf64753a36dd
parent80092f7944c3c9dc83a8da805a0e765b77b49d91 (diff)
downloadfreebsd-ports-021a5b1f66bc8f09e6058f7a525e0261107bab8e.zip
devel/rubygem-hashie2: create port for older hashie gem
Needed by chef-zero PR: 193501 Submitted by: Renaud Chaput <renchap@cocoa-x.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-hashie2/Makefile20
-rw-r--r--devel/rubygem-hashie2/distinfo2
-rw-r--r--devel/rubygem-hashie2/pkg-descr12
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 85619e839d7c..6a369cf22d98 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4340,6 +4340,7 @@
SUBDIR += rubygem-gyoku
SUBDIR += rubygem-hashery
SUBDIR += rubygem-hashie
+ SUBDIR += rubygem-hashie2
SUBDIR += rubygem-highline
SUBDIR += rubygem-hike
SUBDIR += rubygem-hitimes
diff --git a/devel/rubygem-hashie2/Makefile b/devel/rubygem-hashie2/Makefile
new file mode 100644
index 000000000000..123bd7d4be53
--- /dev/null
+++ b/devel/rubygem-hashie2/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= hashie
+PORTVERSION= 2.1.2
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 2
+
+MAINTAINER= renchap@cocoa-x.com
+COMMENT= Hashie is a simple collection of useful Hash extensions
+
+LICENSE= MIT
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST=yes
+
+PORTSCOUT= limit:^2\.
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-hashie2/distinfo b/devel/rubygem-hashie2/distinfo
new file mode 100644
index 000000000000..0e434d53f880
--- /dev/null
+++ b/devel/rubygem-hashie2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/hashie-2.1.2.gem) = a9e1e4928bf4f5a5683ea9c7ef29e50fb93f72542f9a9550e205fe33a6568923
+SIZE (rubygem/hashie-2.1.2.gem) = 34816
diff --git a/devel/rubygem-hashie2/pkg-descr b/devel/rubygem-hashie2/pkg-descr
new file mode 100644
index 000000000000..08ea236075bc
--- /dev/null
+++ b/devel/rubygem-hashie2/pkg-descr
@@ -0,0 +1,12 @@
+Hashie is available as a RubyGem which extend Hashes and make them more useful.
+
+ * Hashie::Mash: gives simple pseudo-object functionality that can be
+ built from hashes and easily extended
+ * Hashie::Dash: has a discrete set of defined properties and only those
+ properties may be set on the hash.
+ * Hashie::Trash: a Dash that allows you to translate keys on
+ initialization.
+ * Hashie::Clash: allows you to easily construct complex hashes using
+ method notation chaining.
+
+WWW: https://github.com/intridea/hashie