summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesús Daniel Colmenares Oviedo <DtxdF@disroot.org>2024-03-10 09:15:11 -0400
committerYasuhiro Kimura <yasu@FreeBSD.org>2024-03-11 09:09:46 +0900
commit324529adaa73d18db025ae7fb993662536c86e64 (patch)
tree3373f3515a720e9522e78789909a72df912b7d39
parent16dff7d2af5afc38f3c4a033aa80102885e0858e (diff)
downloadfreebsd-ports-324529adaa73d18db025ae7fb993662536c86e64.zip
mail/snappymail: Fix autoconfig
When configuring a new domain and hit the Autoconfig button, an error is occurred due the missing SimpleXML extension. ``` [2024-03-09 07:18:28.749][72d59c31] PHP[WARNING]: file_get_contents(https://autoconfig.disroot.org/.well-known/mail-v1.xml?emailaddress=test%40disroot.org): Failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden /usr/local/www/snappymail/snappymail/v/2.35.2/app/libraries/RainLoop/Providers/Domain/Autoconfig.php [line:64, code:2] [2024-03-09 07:18:30.360][72d59c31] PHP[WARNING]: file_get_contents(https://disroot.org/.well-known/autoconfig/mail/config-v1.1.xml): Failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found /usr/local/www/snappymail/snappymail/v/2.35.2/app/libraries/RainLoop/Providers/Domain/Autoconfig.php [line:64, code:2] [2024-03-09 07:18:31.518][72d59c31] SERVICE[WARNING]: Call to undefined function simplexml_load_string() ``` After installing the simplexml extension, it just shows a bunch of warnings, but Autoconfig works and configures the parameters without user intervention. ``` [2024-03-09 07:20:27.683][64f93497] PHP[WARNING]: file_get_contents(https://autoconfig.disroot.org/.well-known/mail-v1.xml?emailaddress=test%40disroot.org): Failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden /usr/local/www/snappymail/snappymail/v/2.35.2/app/libraries/RainLoop/Providers/Domain/Autoconfig.php [line:64, code:2] [2024-03-09 07:20:29.426][64f93497] PHP[WARNING]: file_get_contents(https://disroot.org/.well-known/autoconfig/mail/config-v1.1.xml): Failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found /usr/local/www/snappymail/snappymail/v/2.35.2/app/libraries/RainLoop/Providers/Domain/Autoconfig.php [line:64, code:2] ``` PR: 277611 MFH: 2024Q1 (cherry picked from commit 746736cb56a704b1a915afe15281e5e9e7166cad)
-rw-r--r--mail/snappymail/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/mail/snappymail/Makefile b/mail/snappymail/Makefile
index c202afa3fb46..913fc2869dcc 100644
--- a/mail/snappymail/Makefile
+++ b/mail/snappymail/Makefile
@@ -1,6 +1,6 @@
PORTNAME= snappymail
DISTVERSION= 2.35.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail www
MASTER_SITES= https://github.com/the-djmaze/snappymail/releases/download/v${DISTVERSION}/
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
@@ -15,8 +15,8 @@ RUN_DEPENDS= ${PECL_PKGNAMEPREFIX}APCu>0:devel/pecl-APCu@${PHP_FLAVOR} \
${PECL_PKGNAMEPREFIX}uuid>0:devel/pecl-uuid@${PHP_FLAVOR}
USES= php:web,flavors
-USE_PHP= ctype curl dom fileinfo gd iconv intl mbstring phar sodium tidy \
- xml zip zlib
+USE_PHP= ctype curl dom fileinfo gd iconv intl mbstring phar simplexml \
+ sodium tidy xml zip zlib
NO_ARCH= yes
NO_BUILD= yes