summaryrefslogtreecommitdiff
path: root/examples/stm32f0/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'examples/stm32f0/Cargo.toml')
-rw-r--r--examples/stm32f0/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/examples/stm32f0/Cargo.toml b/examples/stm32f0/Cargo.toml
new file mode 100644
index 00000000..cc2c3f2b
--- /dev/null
+++ b/examples/stm32f0/Cargo.toml
@@ -0,0 +1,29 @@
+[package]
+name = "embassy-stm32f0-examples"
+version = "0.1.0"
+authors = ["Thales Fragoso <thales.fragosoz@gmail.com>"]
+edition = "2018"
+resolver = "2"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+cortex-m = { version = "0.7.1", features = ["inline-asm"] }
+cortex-m-rt = "0.6.13"
+defmt = "0.2.0"
+defmt-rtt = "0.2.0"
+panic-probe = { version = "0.2.0" }
+rtt-target = { version = "0.3", features = ["cortex-m"] }
+embassy = { path = "../../embassy", features = ["defmt"] }
+embassy-stm32 = { path = "../../embassy-stm32", features = ["defmt", "stm32f030f4"] }
+
+[features]
+default = [
+ "defmt-default",
+]
+defmt-default = []
+defmt-trace = []
+defmt-debug = []
+defmt-info = []
+defmt-warn = []
+defmt-error = []