summaryrefslogtreecommitdiff
path: root/embassy-net/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'embassy-net/Cargo.toml')
-rw-r--r--embassy-net/Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/embassy-net/Cargo.toml b/embassy-net/Cargo.toml
index 2143f36d..64d78566 100644
--- a/embassy-net/Cargo.toml
+++ b/embassy-net/Cargo.toml
@@ -16,6 +16,9 @@ std = []
defmt = ["dep:defmt", "smoltcp/defmt"]
+nightly = ["dep:embedded-io", "embedded-io?/async", "dep:embedded-nal-async"]
+unstable-traits = []
+
udp = ["smoltcp/socket-udp"]
tcp = ["smoltcp/socket-tcp"]
dns = ["smoltcp/socket-dns"]
@@ -30,7 +33,6 @@ pool-16 = []
pool-32 = []
pool-64 = []
pool-128 = []
-unstable-traits = []
[dependencies]
@@ -39,7 +41,7 @@ log = { version = "0.4.14", optional = true }
embassy-time = { version = "0.1.0", path = "../embassy-time" }
embassy-sync = { version = "0.1.0", path = "../embassy-sync" }
-embedded-io = { version = "0.3.0", features = [ "async" ] }
+embedded-io = { version = "0.3.0", optional = true }
managed = { version = "0.8.0", default-features = false, features = [ "map" ] }
heapless = { version = "0.7.5", default-features = false }
@@ -49,7 +51,7 @@ stable_deref_trait = { version = "1.2.0", default-features = false }
futures = { version = "0.3.17", default-features = false, features = [ "async-await" ] }
atomic-pool = "1.0"
atomic-polyfill = "1.0.1"
-embedded-nal-async = "0.2.0"
+embedded-nal-async = { version = "0.2.0", optional = true }
[dependencies.smoltcp]
version = "0.8.0"