summaryrefslogtreecommitdiff
path: root/embassy-cortex-m/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'embassy-cortex-m/Cargo.toml')
-rw-r--r--embassy-cortex-m/Cargo.toml47
1 files changed, 47 insertions, 0 deletions
diff --git a/embassy-cortex-m/Cargo.toml b/embassy-cortex-m/Cargo.toml
new file mode 100644
index 00000000..8bd30403
--- /dev/null
+++ b/embassy-cortex-m/Cargo.toml
@@ -0,0 +1,47 @@
+[package]
+name = "embassy-cortex-m"
+version = "0.1.0"
+authors = ["Dario Nieuwenhuis <dirbaio@dirbaio.net>"]
+edition = "2018"
+resolver = "2"
+
+[package.metadata.embassy_docs]
+src_base = "https://github.com/embassy-rs/embassy/blob/embassy-cortex-m-v$VERSION/embassy-cortex-m/src/"
+src_base_git = "https://github.com/embassy-rs/embassy/blob/master/embassy-cortex-m/src/"
+features = []
+flavors = [
+ { name = "thumbv6m-none-eabi", target = "thumbv6m-none-eabi", features = [] },
+ { name = "thumbv7m-none-eabi", target = "thumbv7m-none-eabi", features = [] },
+ { name = "thumbv7em-none-eabi", target = "thumbv7em-none-eabi", features = [] },
+ { name = "thumbv7em-none-eabihf", target = "thumbv7em-none-eabihf", features = [] },
+ { name = "thumbv8m.base-none-eabi", target = "thumbv8m.base-none-eabi", features = [] },
+ { name = "thumbv8m.main-none-eabi", target = "thumbv8m.main-none-eabi", features = [] },
+ { name = "thumbv8m.main-none-eabihf", target = "thumbv8m.main-none-eabihf", features = [] },
+]
+
+[features]
+default = []
+
+# Define the number of NVIC priority bits.
+prio-bits-0 = []
+prio-bits-1 = []
+prio-bits-2 = []
+prio-bits-3 = []
+prio-bits-4 = []
+prio-bits-5 = []
+prio-bits-6 = []
+prio-bits-7 = []
+prio-bits-8 = []
+
+[dependencies]
+defmt = { version = "0.3", optional = true }
+log = { version = "0.4.14", optional = true }
+
+embassy = { version = "0.1.0", path = "../embassy"}
+embassy-macros = { version = "0.1.0", path = "../embassy-macros"}
+embassy-hal-common = { version = "0.1.0", path = "../embassy-hal-common"}
+atomic-polyfill = "0.1.5"
+critical-section = "0.2.5"
+cfg-if = "1.0.0"
+cortex-m = "0.7.3"
+