summaryrefslogtreecommitdiff
path: root/examples/stm32l5/Cargo.toml
diff options
context:
space:
mode:
authorDario Nieuwenhuis <dirbaio@dirbaio.net>2022-07-29 21:58:35 +0200
committerDario Nieuwenhuis <dirbaio@dirbaio.net>2022-07-29 23:40:36 +0200
commita0f1b0ee01d461607660d2d56b5b1bdc57e0d3fb (patch)
treee60fc8f8db8ec07e55d655c1a830b07f4db0b7d2 /examples/stm32l5/Cargo.toml
parent8745d646f0976791b7098456aa61adb983fb1c18 (diff)
downloadembassy-a0f1b0ee01d461607660d2d56b5b1bdc57e0d3fb.zip
Split embassy crate into embassy-executor, embassy-util.
Diffstat (limited to 'examples/stm32l5/Cargo.toml')
-rw-r--r--examples/stm32l5/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/examples/stm32l5/Cargo.toml b/examples/stm32l5/Cargo.toml
index 85eac7b8..6466994e 100644
--- a/examples/stm32l5/Cargo.toml
+++ b/examples/stm32l5/Cargo.toml
@@ -6,7 +6,8 @@ version = "0.1.0"
[features]
[dependencies]
-embassy = { version = "0.1.0", path = "../../embassy", features = ["defmt", "defmt-timestamp-uptime", "time-tick-32768hz"] }
+embassy-util = { version = "0.1.0", path = "../../embassy-util", features = ["defmt"] }
+embassy-executor = { version = "0.1.0", path = "../../embassy-executor", features = ["defmt", "defmt-timestamp-uptime", "time-tick-32768hz"] }
embassy-stm32 = { version = "0.1.0", path = "../../embassy-stm32", features = ["nightly", "defmt", "unstable-pac", "stm32l552ze", "time-driver-any", "exti", "unstable-traits", "memory-x"] }
embassy-usb = { version = "0.1.0", path = "../../embassy-usb", features = ["defmt"] }
embassy-usb-serial = { version = "0.1.0", path = "../../embassy-usb-serial", features = ["defmt"] }