summaryrefslogtreecommitdiff
path: root/examples/stm32f4/Cargo.toml
diff options
context:
space:
mode:
authorchemicstry <chemicstry@gmail.com>2022-02-08 00:32:49 +0200
committerchemicstry <chemicstry@gmail.com>2022-02-08 01:46:32 +0200
commitdb0d798b4896e97bf40e42cb54344e7a3f77a5c8 (patch)
tree1af218e26c9351fa483130d1a46f2b29a3094443 /examples/stm32f4/Cargo.toml
parenta4b4a7bcf995c9dcc32a2944887be853df604a1c (diff)
downloadembassy-db0d798b4896e97bf40e42cb54344e7a3f77a5c8.zip
Add stm32 USB OTG peripherals
Diffstat (limited to 'examples/stm32f4/Cargo.toml')
-rw-r--r--examples/stm32f4/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/examples/stm32f4/Cargo.toml b/examples/stm32f4/Cargo.toml
index 67b212d5..8a5908e2 100644
--- a/examples/stm32f4/Cargo.toml
+++ b/examples/stm32f4/Cargo.toml
@@ -8,7 +8,7 @@ resolver = "2"
[dependencies]
embassy = { version = "0.1.0", path = "../../embassy", features = ["defmt", "unstable-traits"] }
-embassy-stm32 = { version = "0.1.0", path = "../../embassy-stm32", features = ["defmt", "stm32f429zi", "unstable-pac", "memory-x", "time-driver-any", "exti"] }
+embassy-stm32 = { version = "0.1.0", path = "../../embassy-stm32", features = ["defmt", "stm32f429zi", "unstable-pac", "memory-x", "time-driver-any", "exti", "usb-otg-fs"] }
defmt = "0.3"
defmt-rtt = "0.3"
@@ -20,3 +20,6 @@ panic-probe = { version = "0.3", features = ["print-defmt"] }
futures = { version = "0.3.17", default-features = false, features = ["async-await"] }
heapless = { version = "0.7.5", default-features = false }
nb = "1.0.0"
+
+usb-device = "0.2"
+usbd-serial = "0.1.1"