summaryrefslogtreecommitdiff
path: root/examples/stm32f1/Cargo.toml
diff options
context:
space:
mode:
authorSjoerd Simons <sjoerd@collabora.com>2021-12-29 16:03:25 +0100
committerSjoerd Simons <sjoerd@collabora.com>2021-12-30 10:53:01 +0100
commitf0f08f298bc7fd8b60685d3cc11a02a3829b650b (patch)
tree359ec36ba01f55f5fcd7831515d611143a1def8f /examples/stm32f1/Cargo.toml
parent92f2c6d09c3bd2d11d8a5c7a56bd4208f9720895 (diff)
downloadembassy-f0f08f298bc7fd8b60685d3cc11a02a3829b650b.zip
examples: stm32f1: Optimize for size on development builds
Even the basic examples seemingly need to be build optimized for size to allow flashing to a bluepill
Diffstat (limited to 'examples/stm32f1/Cargo.toml')
-rw-r--r--examples/stm32f1/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/examples/stm32f1/Cargo.toml b/examples/stm32f1/Cargo.toml
index 84773b91..765e91b5 100644
--- a/examples/stm32f1/Cargo.toml
+++ b/examples/stm32f1/Cargo.toml
@@ -20,3 +20,6 @@ panic-probe = { version = "0.3", features = ["print-defmt"] }
futures = { version = "0.3.17", default-features = false, features = ["async-await"] }
heapless = { version = "0.7.5", default-features = false }
nb = "1.0.0"
+
+[profile.dev]
+opt-level = "s"