summaryrefslogtreecommitdiff
path: root/examples/stm32f1/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2021-11-15 18:31:38 +0000
committerGitHub <noreply@github.com>2021-11-15 18:31:38 +0000
commitc8f3ec3fba47899b123d0a146e8f9b3808ea4601 (patch)
treeba19e675d923441025e6b1c9d8114f85c86f8b6d /examples/stm32f1/Cargo.toml
parent4e0a0f27febfb00c9b4ec42275ac6b83c98436ea (diff)
parentee1490bce16d98457c1e67f5c7e9320e4c17e51b (diff)
downloadembassy-c8f3ec3fba47899b123d0a146e8f9b3808ea4601.zip
Merge #487
487: Update to defmt 3.0ish. r=bobmcwhirter a=bobmcwhirter Lots of gitrevs deps. Co-authored-by: Bob McWhirter <bmcwhirt@redhat.com>
Diffstat (limited to 'examples/stm32f1/Cargo.toml')
-rw-r--r--examples/stm32f1/Cargo.toml21
1 files changed, 5 insertions, 16 deletions
diff --git a/examples/stm32f1/Cargo.toml b/examples/stm32f1/Cargo.toml
index 9b4e831e..0edfacd9 100644
--- a/examples/stm32f1/Cargo.toml
+++ b/examples/stm32f1/Cargo.toml
@@ -5,30 +5,19 @@ name = "embassy-stm32f1-examples"
version = "0.1.0"
resolver = "2"
-[features]
-default = [
- "defmt-default",
-]
-defmt-default = []
-defmt-trace = []
-defmt-debug = []
-defmt-info = []
-defmt-warn = []
-defmt-error = []
-
[dependencies]
-embassy = { version = "0.1.0", path = "../../embassy", features = ["defmt", "defmt-trace"] }
+embassy = { version = "0.1.0", path = "../../embassy", features = ["defmt"] }
embassy-traits = { version = "0.1.0", path = "../../embassy-traits", features = ["defmt"] }
-embassy-stm32 = { version = "0.1.0", path = "../../embassy-stm32", features = ["defmt", "defmt-trace", "stm32f103c8", "unstable-pac", "memory-x", "time-driver-tim2"] }
+embassy-stm32 = { version = "0.1.0", path = "../../embassy-stm32", features = ["defmt", "stm32f103c8", "unstable-pac", "memory-x", "time-driver-tim2"] }
embassy-hal-common = {version = "0.1.0", path = "../../embassy-hal-common" }
-defmt = "0.2.3"
-defmt-rtt = "0.2.0"
+defmt = "0.3"
+defmt-rtt = "0.3"
cortex-m = "0.7.3"
cortex-m-rt = "0.7.0"
embedded-hal = "0.2.6"
-panic-probe = { version = "0.2.0", features = ["print-defmt"] }
+panic-probe = { version = "0.3", features = ["print-defmt"] }
futures = { version = "0.3.17", default-features = false, features = ["async-await"] }
rtt-target = { version = "0.3.1", features = ["cortex-m"] }
heapless = { version = "0.7.5", default-features = false }