summaryrefslogtreecommitdiff
path: root/examples/stm32f1/Cargo.toml
diff options
context:
space:
mode:
authorMariusz Ryndzionek <mryndzionek@gmail.com>2021-09-26 17:08:22 +0200
committerMariusz Ryndzionek <mryndzionek@gmail.com>2021-09-28 18:31:04 +0200
commitbce909ec1eea95f93a6887aae5aa0b37d953ec85 (patch)
treed22557144ceab9172e8b1d4784fab870d48b9816 /examples/stm32f1/Cargo.toml
parent1650983e463e5f237d68957b0de1537f807cbc63 (diff)
downloadembassy-bce909ec1eea95f93a6887aae5aa0b37d953ec85.zip
Initial STM32F1 family support with two examples for STM32F103C8 (Blue Pill)
Diffstat (limited to 'examples/stm32f1/Cargo.toml')
-rw-r--r--examples/stm32f1/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/examples/stm32f1/Cargo.toml b/examples/stm32f1/Cargo.toml
new file mode 100644
index 00000000..9b4e831e
--- /dev/null
+++ b/examples/stm32f1/Cargo.toml
@@ -0,0 +1,35 @@
+[package]
+authors = ["Dario Nieuwenhuis <dirbaio@dirbaio.net>"]
+edition = "2018"
+name = "embassy-stm32f1-examples"
+version = "0.1.0"
+resolver = "2"
+
+[features]
+default = [
+ "defmt-default",
+]
+defmt-default = []
+defmt-trace = []
+defmt-debug = []
+defmt-info = []
+defmt-warn = []
+defmt-error = []
+
+[dependencies]
+embassy = { version = "0.1.0", path = "../../embassy", features = ["defmt", "defmt-trace"] }
+embassy-traits = { version = "0.1.0", path = "../../embassy-traits", features = ["defmt"] }
+embassy-stm32 = { version = "0.1.0", path = "../../embassy-stm32", features = ["defmt", "defmt-trace", "stm32f103c8", "unstable-pac", "memory-x", "time-driver-tim2"] }
+embassy-hal-common = {version = "0.1.0", path = "../../embassy-hal-common" }
+
+defmt = "0.2.3"
+defmt-rtt = "0.2.0"
+
+cortex-m = "0.7.3"
+cortex-m-rt = "0.7.0"
+embedded-hal = "0.2.6"
+panic-probe = { version = "0.2.0", features = ["print-defmt"] }
+futures = { version = "0.3.17", default-features = false, features = ["async-await"] }
+rtt-target = { version = "0.3.1", features = ["cortex-m"] }
+heapless = { version = "0.7.5", default-features = false }
+nb = "1.0.0"