summaryrefslogtreecommitdiff
path: root/examples/stm32f1/Cargo.toml
diff options
context:
space:
mode:
authorBob McWhirter <bmcwhirt@redhat.com>2021-11-15 11:19:19 -0500
committerBob McWhirter <bmcwhirt@redhat.com>2021-11-15 11:19:19 -0500
commita770fc77c907c50fd2c4a7f6ce934eb45974ae55 (patch)
tree1ffee8ef80106cd53a14a01a8f90c4ff5ef4dd4f /examples/stm32f1/Cargo.toml
parentc2da49826345e82e7539fce3e96cce203253dc56 (diff)
downloadembassy-a770fc77c907c50fd2c4a7f6ce934eb45974ae55.zip
Adjust all examples to defmt 0.3.
Diffstat (limited to 'examples/stm32f1/Cargo.toml')
-rw-r--r--examples/stm32f1/Cargo.toml21
1 files changed, 5 insertions, 16 deletions
diff --git a/examples/stm32f1/Cargo.toml b/examples/stm32f1/Cargo.toml
index 9b4e831e..0edfacd9 100644
--- a/examples/stm32f1/Cargo.toml
+++ b/examples/stm32f1/Cargo.toml
@@ -5,30 +5,19 @@ name = "embassy-stm32f1-examples"
version = "0.1.0"
resolver = "2"
-[features]
-default = [
- "defmt-default",
-]
-defmt-default = []
-defmt-trace = []
-defmt-debug = []
-defmt-info = []
-defmt-warn = []
-defmt-error = []
-
[dependencies]
-embassy = { version = "0.1.0", path = "../../embassy", features = ["defmt", "defmt-trace"] }
+embassy = { version = "0.1.0", path = "../../embassy", features = ["defmt"] }
embassy-traits = { version = "0.1.0", path = "../../embassy-traits", features = ["defmt"] }
-embassy-stm32 = { version = "0.1.0", path = "../../embassy-stm32", features = ["defmt", "defmt-trace", "stm32f103c8", "unstable-pac", "memory-x", "time-driver-tim2"] }
+embassy-stm32 = { version = "0.1.0", path = "../../embassy-stm32", features = ["defmt", "stm32f103c8", "unstable-pac", "memory-x", "time-driver-tim2"] }
embassy-hal-common = {version = "0.1.0", path = "../../embassy-hal-common" }
-defmt = "0.2.3"
-defmt-rtt = "0.2.0"
+defmt = "0.3"
+defmt-rtt = "0.3"
cortex-m = "0.7.3"
cortex-m-rt = "0.7.0"
embedded-hal = "0.2.6"
-panic-probe = { version = "0.2.0", features = ["print-defmt"] }
+panic-probe = { version = "0.3", features = ["print-defmt"] }
futures = { version = "0.3.17", default-features = false, features = ["async-await"] }
rtt-target = { version = "0.3.1", features = ["cortex-m"] }
heapless = { version = "0.7.5", default-features = false }