summaryrefslogtreecommitdiff
path: root/examples/boot/stm32l4/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2022-05-31 21:55:40 +0000
committerGitHub <noreply@github.com>2022-05-31 21:55:40 +0000
commit0adb4c926b15f9773fb83497a7bf1eb3789286da (patch)
treee94f12eea8a64a3dd22eaef7400f02714ea2fb59 /examples/boot/stm32l4/Cargo.toml
parenta0d43c863dd9859e94e5d202d5b5bb6b107f152c (diff)
parent108967417562cf398ba264295014d9e18f2c0707 (diff)
downloadembassy-0adb4c926b15f9773fb83497a7bf1eb3789286da.zip
Merge #784
784: stm32: make tick rate configurable r=Dirbaio a=willglynn The stm32 time drivers support arbitrary tick rates but the associated Cargo features do not. Enabling any time driver presently enables `embassy/time-tick-32768hz`; instead, enable only `embassy/time`. Additionally, `embassy/time` now functions in the absence of any `embassy/time-tick-*` feature, defaulting to 32768 Hz if left unspecified. Co-authored-by: Will Glynn <will@willglynn.com> Co-authored-by: Dario Nieuwenhuis <dirbaio@dirbaio.net>
Diffstat (limited to 'examples/boot/stm32l4/Cargo.toml')
-rw-r--r--examples/boot/stm32l4/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/boot/stm32l4/Cargo.toml b/examples/boot/stm32l4/Cargo.toml
index 705dbd0d..234ea9b5 100644
--- a/examples/boot/stm32l4/Cargo.toml
+++ b/examples/boot/stm32l4/Cargo.toml
@@ -5,7 +5,7 @@ name = "embassy-boot-stm32l4-examples"
version = "0.1.0"
[dependencies]
-embassy = { version = "0.1.0", path = "../../../embassy", features = ["nightly"] }
+embassy = { version = "0.1.0", path = "../../../embassy", features = ["nightly", "time-tick-32768hz"] }
embassy-stm32 = { version = "0.1.0", path = "../../../embassy-stm32", features = ["unstable-traits", "nightly", "stm32l475vg", "time-driver-any", "exti"] }
embassy-boot-stm32 = { version = "0.1.0", path = "../../../embassy-boot/stm32" }
embassy-embedded-hal = { version = "0.1.0", path = "../../../embassy-embedded-hal" }