summaryrefslogtreecommitdiff
path: root/embassy-rp/Cargo.toml
diff options
context:
space:
mode:
authorDario Nieuwenhuis <dirbaio@dirbaio.net>2022-08-14 23:16:06 +0200
committerDario Nieuwenhuis <dirbaio@dirbaio.net>2022-08-17 19:01:56 +0200
commit67edea41686084a444e1455d17d5482b10c54abd (patch)
treee9d4cf483195fce6c8c34c514fc9a5e338771ce9 /embassy-rp/Cargo.toml
parent16d0ae76782475c0f759c3310e068507a0a9f8ab (diff)
downloadembassy-67edea41686084a444e1455d17d5482b10c54abd.zip
Update to critical-section 1.0, atomic-polyfill 1.0
Diffstat (limited to 'embassy-rp/Cargo.toml')
-rw-r--r--embassy-rp/Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/embassy-rp/Cargo.toml b/embassy-rp/Cargo.toml
index 303617ff..eeb4ec43 100644
--- a/embassy-rp/Cargo.toml
+++ b/embassy-rp/Cargo.toml
@@ -33,12 +33,12 @@ embassy-cortex-m = { version = "0.1.0", path = "../embassy-cortex-m", features =
embassy-hal-common = {version = "0.1.0", path = "../embassy-hal-common" }
embassy-embedded-hal = {version = "0.1.0", path = "../embassy-embedded-hal" }
embassy-macros = { version = "0.1.0", path = "../embassy-macros", features = ["rp"]}
-atomic-polyfill = "0.1.5"
+atomic-polyfill = "1.0.1"
defmt = { version = "0.3", optional = true }
log = { version = "0.4.14", optional = true }
cortex-m-rt = ">=0.6.15,<0.8"
-cortex-m = "0.7.3"
-critical-section = "0.2.5"
+cortex-m = "0.7.6"
+critical-section = "1.1"
futures = { version = "0.3.17", default-features = false, features = ["async-await"] }
rp2040-pac2 = { git = "https://github.com/embassy-rs/rp2040-pac2", rev="9ad7223a48a065e612bc7dc7be5bf5bd0b41cfc4", features = ["rt"] }