summaryrefslogtreecommitdiff
path: root/embassy-rp/Cargo.toml
diff options
context:
space:
mode:
authorDario Nieuwenhuis <dirbaio@dirbaio.net>2021-03-29 04:11:32 +0200
committerDario Nieuwenhuis <dirbaio@dirbaio.net>2021-03-29 21:35:25 +0200
commit2cd3bdc90cf5da6d07ddad91e875733b8e354dc5 (patch)
tree846d9ef3d4b3171a6fcf4febe1a79aefa23cd378 /embassy-rp/Cargo.toml
parent2bcd1aaebbf255de1ded97356c107df5bea04e57 (diff)
downloadembassy-2cd3bdc90cf5da6d07ddad91e875733b8e354dc5.zip
rp: add initial version
Diffstat (limited to 'embassy-rp/Cargo.toml')
-rw-r--r--embassy-rp/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/embassy-rp/Cargo.toml b/embassy-rp/Cargo.toml
new file mode 100644
index 00000000..1d11fb0d
--- /dev/null
+++ b/embassy-rp/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "embassy-rp"
+version = "0.1.0"
+authors = ["Dario Nieuwenhuis <dirbaio@dirbaio.net>"]
+edition = "2018"
+
+[features]
+defmt-trace = [ ]
+defmt-debug = [ ]
+defmt-info = [ ]
+defmt-warn = [ ]
+defmt-error = [ ]
+
+[dependencies]
+embassy = { version = "0.1.0", path = "../embassy" }
+embassy-extras = {version = "0.1.0", path = "../embassy-extras" }
+embassy-macros = { version = "0.1.0", path = "../embassy-macros", features = ["rp"]}
+
+defmt = { version = "0.2.0", optional = true }
+log = { version = "0.4.11", optional = true }
+cortex-m-rt = "0.6.13"
+cortex-m = "0.7.1"
+
+rp2040-pac2 = { git = "https://github.com/Dirbaio/rp2040-pac", rev="254f4677937801155ca3cb17c7bb9d38eb62683e", features = ["rt"] }
+embedded-hal = { version = "0.2.4", features = [ "unproven" ] }