summaryrefslogtreecommitdiff
path: root/embassy-lora/Cargo.toml
diff options
context:
space:
mode:
authorceekdee <taigatensor@gmail.com>2022-10-10 12:35:42 -0500
committerceekdee <taigatensor@gmail.com>2022-10-10 12:35:42 -0500
commit327d3cf0df7a1b116ea7ec44d36a569e6ba6ca16 (patch)
tree67c69a2d511ba9dee2def2f7858e859d8150559b /embassy-lora/Cargo.toml
parent79ba20d315f456ac525daf4c3d5dd0d2ce92ad2b (diff)
downloadembassy-327d3cf0df7a1b116ea7ec44d36a569e6ba6ca16.zip
Change rak4631 feature to sx126x, removing use in board-specific processing; simplify the P2P examples; correct RSSI computation.
Diffstat (limited to 'embassy-lora/Cargo.toml')
-rw-r--r--embassy-lora/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/embassy-lora/Cargo.toml b/embassy-lora/Cargo.toml
index bcb837d9..ea2c3fe6 100644
--- a/embassy-lora/Cargo.toml
+++ b/embassy-lora/Cargo.toml
@@ -9,7 +9,7 @@ src_base = "https://github.com/embassy-rs/embassy/blob/embassy-lora-v$VERSION/em
src_base_git = "https://github.com/embassy-rs/embassy/blob/$COMMIT/embassy-lora/src/"
features = ["time", "defmt"]
flavors = [
- { name = "rak4631", target = "thumbv7em-none-eabihf", features = ["rak4631"] },
+ { name = "sx126x", target = "thumbv7em-none-eabihf", features = ["sx126x"] },
{ name = "sx127x", target = "thumbv7em-none-eabihf", features = ["sx127x", "embassy-stm32/stm32wl55jc-cm4", "embassy-stm32/time-driver-any"] },
{ name = "stm32wl", target = "thumbv7em-none-eabihf", features = ["stm32wl", "embassy-stm32/stm32wl55jc-cm4", "embassy-stm32/time-driver-any"] },
]
@@ -17,7 +17,7 @@ flavors = [
[lib]
[features]
-rak4631 = []
+sx126x = []
sx127x = []
stm32wl = ["embassy-stm32", "embassy-stm32/subghz"]
time = []