summaryrefslogtreecommitdiff
path: root/embassy-boot/nrf/Cargo.toml
diff options
context:
space:
mode:
authorUlf Lilleengen <ulf.lilleengen@gmail.com>2022-04-19 14:42:38 +0200
committerUlf Lilleengen <ulf.lilleengen@gmail.com>2022-04-19 20:07:06 +0200
commit2afff617f652d0fdcfa9ffcfd49062e3d2c996a3 (patch)
treebc531122365086cd24a12a9331c94f9f042cad3a /embassy-boot/nrf/Cargo.toml
parente2ed41b3832db17633ae8ae1ee9391639c3a9229 (diff)
downloadembassy-2afff617f652d0fdcfa9ffcfd49062e3d2c996a3.zip
Support multiple flash instances in embassy-boot
* Add FlashProvider and FlashConfig traits to define flash characteristics * Use traits in bootloader to retrieve flash handles and for copying data between flash instances * Add convenience implementations for using a single flash instance.
Diffstat (limited to 'embassy-boot/nrf/Cargo.toml')
-rw-r--r--embassy-boot/nrf/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/embassy-boot/nrf/Cargo.toml b/embassy-boot/nrf/Cargo.toml
index 512e7d37..97207ac2 100644
--- a/embassy-boot/nrf/Cargo.toml
+++ b/embassy-boot/nrf/Cargo.toml
@@ -12,7 +12,7 @@ defmt = { version = "0.3", optional = true }
defmt-rtt = { version = "0.3", optional = true }
embassy = { path = "../../embassy", default-features = false }
-embassy-nrf = { path = "../../embassy-nrf", default-features = false }
+embassy-nrf = { path = "../../embassy-nrf", default-features = false, features = ["nightly"] }
embassy-boot = { path = "../boot", default-features = false }
cortex-m = { version = "0.7" }
cortex-m-rt = { version = "0.7" }