summaryrefslogtreecommitdiff
path: root/docs/modules/ROOT/examples/layer-by-layer/blinky-irq/Cargo.toml
diff options
context:
space:
mode:
authorUlf Lilleengen <ulf.lilleengen@gmail.com>2022-02-23 09:48:32 +0100
committerUlf Lilleengen <ulf.lilleengen@gmail.com>2022-02-23 09:48:32 +0100
commit092eef3ae7f90e33564f09fa6a887e8fc9ed88b8 (patch)
tree547db6b7241e749f1cad0285c12124d26de37639 /docs/modules/ROOT/examples/layer-by-layer/blinky-irq/Cargo.toml
parent4c6e61b3b1a82212510695b0d202bc8612b16b6c (diff)
downloadembassy-092eef3ae7f90e33564f09fa6a887e8fc9ed88b8.zip
Add documentation about the different embassy abstraction layers
The guide demonstrates the functionality offered by each layer in Embassy, using code examples.
Diffstat (limited to 'docs/modules/ROOT/examples/layer-by-layer/blinky-irq/Cargo.toml')
-rw-r--r--docs/modules/ROOT/examples/layer-by-layer/blinky-irq/Cargo.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/docs/modules/ROOT/examples/layer-by-layer/blinky-irq/Cargo.toml b/docs/modules/ROOT/examples/layer-by-layer/blinky-irq/Cargo.toml
new file mode 100644
index 00000000..0dd32601
--- /dev/null
+++ b/docs/modules/ROOT/examples/layer-by-layer/blinky-irq/Cargo.toml
@@ -0,0 +1,13 @@
+[package]
+name = "blinky-irq"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+cortex-m = "0.7"
+cortex-m-rt = { version = "0.7" }
+embassy-stm32 = { version = "0.1.0", features = ["stm32l475vg", "memory-x", "unstable-pac"] }
+
+defmt = "0.3.0"
+defmt-rtt = "0.3.0"
+panic-probe = { version = "0.3.0", features = ["print-defmt"] }