summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control52
-rwxr-xr-xdebian/rules16
2 files changed, 34 insertions, 34 deletions
diff --git a/debian/control b/debian/control
index 52a0e1f4..cf05ffa2 100644
--- a/debian/control
+++ b/debian/control
@@ -6,17 +6,17 @@ Priority: optional
Build-Depends: debhelper (>= 12~),
dh-python,
python3-all,
- python3-antsibull <!nodoc>,
+# python3-antsibull <!nodoc>,
python3-pycryptodome,
python3-jinja2,
python3-packaging,
- python3-pygments <!nodoc>,
- python3-rstcheck <!nodoc>,
+# python3-pygments <!nodoc>,
+# python3-rstcheck <!nodoc>,
python3-setuptools,
- python3-straight.plugin <!nodoc>,
- python3-sphinx <!nodoc>,
- python3-sphinx-notfound-page <!nodoc>,
- python3-sphinx-rtd-theme <!nodoc>,
+# python3-straight.plugin <!nodoc>,
+# python3-sphinx <!nodoc>,
+# python3-sphinx-notfound-page <!nodoc>,
+# python3-sphinx-rtd-theme <!nodoc>,
python3-yaml,
sphinx-common
Rules-Requires-Root: no
@@ -59,22 +59,22 @@ Description: Configuration management, deployment, and task execution system
.
This package contains the ansible binaries.
-Package: ansible-doc
-Architecture: all
-Section: doc
-Depends: ${misc:Depends},
- ${sphinxdoc:Depends},
- fonts-font-awesome,
- fonts-roboto-fontface,
- libjs-jquery,
- libjs-modernizr,
- libjs-underscore
-Description: Ansible documentation and examples
- Ansible is a radically simple model-driven configuration management,
- multi-node deployment, and remote task execution system. Ansible works
- over SSH and does not require any software or daemons to be installed
- on remote nodes. Extension modules can be written in any language and
- are transferred to managed machines automatically.
- .
- This package contains HTML documentation and examples.
-Build-Profiles: <!nodoc>
+#Package: ansible-doc
+#Architecture: all
+#Section: doc
+#Depends: ${misc:Depends},
+# ${sphinxdoc:Depends},
+# fonts-font-awesome,
+# fonts-roboto-fontface,
+# libjs-jquery,
+# libjs-modernizr,
+# libjs-underscore
+#Description: Ansible documentation and examples
+# Ansible is a radically simple model-driven configuration management,
+# multi-node deployment, and remote task execution system. Ansible works
+# over SSH and does not require any software or daemons to be installed
+# on remote nodes. Extension modules can be written in any language and
+# are transferred to managed machines automatically.
+# .
+# This package contains HTML documentation and examples.
+#Build-Profiles: <!nodoc>
diff --git a/debian/rules b/debian/rules
index 3f983609..4ad0a809 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,14 +8,14 @@ DOPACKAGES = $(shell dh_listpackages)
override_dh_clean:
dh_clean --exclude=test/units/inventory_test_data/group_vars/noparse/all.yml~
-override_dh_auto_build:
- dh_auto_build
-ifneq (,$(filter ansible-doc,$(DOPACKAGES)))
- # html documentation
- $(MAKE) webdocs
- # manpage documentation
- $(MAKE) docs
-endif
+#override_dh_auto_build:
+# dh_auto_build
+#ifneq (,$(filter ansible-doc,$(DOPACKAGES)))
+# # html documentation
+# $(MAKE) webdocs
+# # manpage documentation
+# $(MAKE) docs
+#endif
override_dh_auto_test:
# For now, disable the tests