summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..3f983609
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,29 @@
+#!/usr/bin/make -f
+
+DOPACKAGES = $(shell dh_listpackages)
+
+%:
+ dh $@ --with python3,sphinxdoc --buildsystem=pybuild
+
+override_dh_clean:
+ dh_clean --exclude=test/units/inventory_test_data/group_vars/noparse/all.yml~
+
+override_dh_auto_build:
+ dh_auto_build
+ifneq (,$(filter ansible-doc,$(DOPACKAGES)))
+ # html documentation
+ $(MAKE) webdocs
+ # manpage documentation
+ $(MAKE) docs
+endif
+
+override_dh_auto_test:
+ # For now, disable the tests
+ #make tests-nonet
+
+override_dh_python3:
+ dh_python3 --shebang=/usr/bin/python3
+
+execute_after_dh_auto_install:
+ find debian/tmp/usr/lib/ -name '.git*' -delete
+ find debian/tmp/usr/lib/ -name '.travis.yml' -delete