summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog11
-rw-r--r--debian/control6
-rw-r--r--debian/gbp.conf3
-rw-r--r--debian/patches/0005-use-py3.patch45
-rw-r--r--debian/patches/series2
-rw-r--r--debian/watch2
6 files changed, 18 insertions, 51 deletions
diff --git a/debian/changelog b/debian/changelog
index 834dfd66..c2b0535c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+ansible-core (2.16.5-1) unstable; urgency=medium
+
+ * New upstream release (Closes: #1057640)
+ - ansible-test supports python 3.12 now (Closes: #1061782, #1061781)
+ - fixes CVE-2024-0690 (Closes: #1061156)
+ * Drop dependency on python3-distutils (Closes: #1065826)
+ * Drop patches applied upstream
+ * Refreshen patches
+
+ -- Lee Garrett <debian@rocketjump.eu> Wed, 17 Apr 2024 23:47:08 +0200
+
ansible-core (2.14.13-1) unstable; urgency=medium
* New upstream version 2.14.13
diff --git a/debian/control b/debian/control
index e64426c4..82f7c2a8 100644
--- a/debian/control
+++ b/debian/control
@@ -1,5 +1,6 @@
Source: ansible-core
-Maintainer: Lee Garrett <debian@rocketjump.eu>
+Maintainer: Debian Python Team <team+python@tracker.debian.org>
+Uploaders: Lee Garrett <debian@rocketjump.eu>
Section: admin
Priority: optional
Build-Depends: debhelper-compat (= 13),
@@ -32,13 +33,12 @@ Architecture: all
Depends: ${misc:Depends},
${python3:Depends},
openssh-client | python3-paramiko (>= 2.6.0),
- python3-distutils,
python3-dnspython,
python3-httplib2,
python3-jinja2 (>= 3.0.0~),
python3-netaddr,
python3-yaml (>= 5.1~)
-Recommends: ansible (>= 7.0.0-1~),
+Recommends: ansible (>= 9.4.0-1~),
python3-argcomplete,
python3-cryptography,
python3-jmespath,
diff --git a/debian/gbp.conf b/debian/gbp.conf
index 12c60219..514ccaf5 100644
--- a/debian/gbp.conf
+++ b/debian/gbp.conf
@@ -4,3 +4,6 @@
debian-branch = debian/latest
upstream-branch = upstream/latest
pristine-tar = True
+
+[import-orig]
+merge-mode = replace
diff --git a/debian/patches/0005-use-py3.patch b/debian/patches/0005-use-py3.patch
index 873918fa..0db80e1e 100644
--- a/debian/patches/0005-use-py3.patch
+++ b/debian/patches/0005-use-py3.patch
@@ -40,21 +40,6 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
# -*- coding: utf-8 -*-
---- a/test/integration/targets/group/files/gidget.py
-+++ b/test/integration/targets/group/files/gidget.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- from __future__ import (absolute_import, division, print_function)
- __metaclass__ = type
---- a/test/integration/targets/module_utils/module_utils/foo.py
-+++ b/test/integration/targets/module_utils/module_utils/foo.py
-@@ -1,3 +1,3 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- foo = "FOO FROM foo.py"
--- a/test/integration/targets/module_utils/module_utils/sub/bam.py
+++ b/test/integration/targets/module_utils/module_utils/sub/bam.py
@@ -1,3 +1,3 @@
@@ -69,20 +54,6 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+#!/usr/bin/env python3
bam = "BAM FROM sub/bam/bam.py"
---- a/test/integration/targets/module_utils/module_utils/sub/bar/bam.py
-+++ b/test/integration/targets/module_utils/module_utils/sub/bar/bam.py
-@@ -1,3 +1,3 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- bam = "BAM FROM sub/bar/bam.py"
---- a/test/integration/targets/module_utils/module_utils/sub/bar/bar.py
-+++ b/test/integration/targets/module_utils/module_utils/sub/bar/bar.py
-@@ -1,3 +1,3 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- bar = "BAR FROM sub/bar/bar.py"
--- a/test/integration/targets/pause/test-pause.py
+++ b/test/integration/targets/pause/test-pause.py
@@ -1,4 +1,4 @@
@@ -218,22 +189,6 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
assert set(inv['_meta']['hostvars']['test_host']['departments']) == set(['paris'])"
export ANSIBLE_CACHE_PLUGINS=cache_plugins/
---- a/test/units/modules/test_async_wrapper.py
-+++ b/test/units/modules/test_async_wrapper.py
-@@ -22,11 +22,11 @@
- def test_run_module(self, monkeypatch):
-
- def mock_get_interpreter(module_path):
-- return ['/usr/bin/python']
-+ return ['/usr/bin/python3']
-
- module_result = {'rc': 0}
- module_lines = [
-- '#!/usr/bin/python',
-+ '#!/usr/bin/python3',
- 'import sys',
- 'sys.stderr.write("stderr stuff")',
- "print('%s')" % json.dumps(module_result)
--- a/bin/ansible-test
+++ b/bin/ansible-test
@@ -1,4 +1,4 @@
diff --git a/debian/patches/series b/debian/patches/series
index 340d630e..66bfa3f5 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1 @@
0005-use-py3.patch
-0009-resolvelib_compat.patch
-0010-fix-facter.patch
diff --git a/debian/watch b/debian/watch
index e98fc57c..ae1cc690 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,4 +1,4 @@
version=4
opts=dversionmangle=s/\+dfsg//,repacksuffix=+dfsg \
-https://pypi.debian.net/ansible-core/ ansible-core-(2\.14\.[0-9]+).tar.gz
+https://pypi.debian.net/ansible-core/ ansible-core-([0-9]+\.[0-9]+\.[0-9]+).tar.gz