summaryrefslogtreecommitdiff
path: root/packaging
diff options
context:
space:
mode:
authorLee Garrett <lgarrett@rocketjump.eu>2022-06-13 23:13:57 +0200
committerLee Garrett <lgarrett@rocketjump.eu>2022-06-13 23:13:57 +0200
commitdf2a2cd18c338647061f3448248f8b97b6971f49 (patch)
treef223b6b9084be551de18fdb4fe0d596c68a9cebc /packaging
parent71ed02a1e802462d5d9b5f7e0fad42307a175278 (diff)
downloaddebian-ansible-core-df2a2cd18c338647061f3448248f8b97b6971f49.zip
New upstream version 2.13.0
Diffstat (limited to 'packaging')
-rw-r--r--packaging/arch/README.md8
-rw-r--r--packaging/debian/Dockerfile20
-rw-r--r--packaging/debian/README.md39
-rw-r--r--packaging/debian/ansible-core.dirs4
-rw-r--r--packaging/debian/ansible-core.install15
-rw-r--r--packaging/debian/ansible-test.install2
-rw-r--r--packaging/debian/changelog5
-rw-r--r--packaging/debian/compat1
-rw-r--r--packaging/debian/control29
-rw-r--r--packaging/debian/copyright26
-rw-r--r--packaging/debian/docs1
-rw-r--r--packaging/debian/pycompat1
-rwxr-xr-xpackaging/debian/rules9
-rw-r--r--packaging/gentoo/README.md3
-rw-r--r--packaging/macports/.gitignore2
-rw-r--r--packaging/macports/README.md39
-rw-r--r--packaging/macports/sysutils/ansible/Portfile67
17 files changed, 0 insertions, 271 deletions
diff --git a/packaging/arch/README.md b/packaging/arch/README.md
deleted file mode 100644
index 994daca7..00000000
--- a/packaging/arch/README.md
+++ /dev/null
@@ -1,8 +0,0 @@
-Arch Packaging Files
---------------------
-
-You can find the source files for [ansible-git][1] in the [Arch User Repository][2] and for the stable version [ansible][3] you can do so in \[community\].
-
- [1]: https://aur.archlinux.org/packages/ansible-git/
- [2]: https://wiki.archlinux.org/index.php/Arch_User_Repository
- [3]: https://www.archlinux.org/packages/community/any/ansible/
diff --git a/packaging/debian/Dockerfile b/packaging/debian/Dockerfile
deleted file mode 100644
index de831d09..00000000
--- a/packaging/debian/Dockerfile
+++ /dev/null
@@ -1,20 +0,0 @@
-FROM ubuntu:xenial
-
-RUN apt-get update && apt-get install -y \
- python-docutils \
- cdbs \
- debootstrap \
- devscripts \
- make \
- pbuilder \
- python-jinja2 \
- python-setuptools \
- python-yaml \
- && \
- apt-get clean
-
-VOLUME /ansible
-WORKDIR /ansible
-
-ENTRYPOINT ["/bin/bash", "-c"]
-CMD ["make deb"]
diff --git a/packaging/debian/README.md b/packaging/debian/README.md
deleted file mode 100644
index 7eaa4721..00000000
--- a/packaging/debian/README.md
+++ /dev/null
@@ -1,39 +0,0 @@
-Ansible Debian Package
-======================
-
-To create an Ansible DEB package:
-
-__Note__: You must run this target as root or set `PBUILDER_BIN='sudo pbuilder'`
-
-```
-apt-get install python-docutils cdbs debootstrap devscripts make pbuilder python-setuptools
-git clone https://github.com/ansible/ansible.git
-cd ansible
-DEB_DIST='xenial trusty precise' make deb
-```
-
-Building in Docker:
-
-```
-git clone https://github.com/ansible/ansible.git
-cd ansible
-docker build -t ansible-deb-builder -f packaging/debian/Dockerfile .
-docker run --privileged -e DEB_DIST='trusty' -v $(pwd):/ansible ansible-deb-builder
-```
-
-The debian package file will be placed in the `deb-build` directory. This can then be added to an APT repository or installed with `dpkg -i <package-file>`.
-
-Note that `dpkg -i` does not resolve dependencies.
-
-To install the Ansible DEB package and resolve dependencies:
-
-```
-dpkg -i <package-file>
-apt-get -fy install
-```
-
-Or, if you are running Debian Stretch (or later) or Ubuntu Xenial (or later):
-
-```
-apt install /path/to/<package-file>
-```
diff --git a/packaging/debian/ansible-core.dirs b/packaging/debian/ansible-core.dirs
deleted file mode 100644
index fba15a43..00000000
--- a/packaging/debian/ansible-core.dirs
+++ /dev/null
@@ -1,4 +0,0 @@
-etc/ansible
-etc/ansible/roles
-usr/lib/python3/dist-packages/ansible
-usr/share/ansible
diff --git a/packaging/debian/ansible-core.install b/packaging/debian/ansible-core.install
deleted file mode 100644
index d2dac7c1..00000000
--- a/packaging/debian/ansible-core.install
+++ /dev/null
@@ -1,15 +0,0 @@
-examples/hosts etc/ansible
-docs/man/man1/*.1 usr/share/man/man1
-debian/tmp/usr/bin/ansible-galaxy usr/bin
-debian/tmp/usr/bin/ansible-vault usr/bin
-debian/tmp/usr/bin/ansible-doc usr/bin
-debian/tmp/usr/bin/ansible-console usr/bin
-debian/tmp/usr/bin/ansible-connection usr/bin
-debian/tmp/usr/bin/ansible-inventory usr/bin
-debian/tmp/usr/bin/ansible-config usr/bin
-debian/tmp/usr/bin/ansible-pull usr/bin
-debian/tmp/usr/bin/ansible-playbook usr/bin
-debian/tmp/usr/bin/ansible usr/bin
-examples/ansible.cfg etc/ansible
-debian/tmp/usr/lib/python3/dist-packages/ansible usr/lib/python3/dist-packages
-debian/tmp/usr/lib/python3/dist-packages/ansible_*.egg-info
diff --git a/packaging/debian/ansible-test.install b/packaging/debian/ansible-test.install
deleted file mode 100644
index 92528905..00000000
--- a/packaging/debian/ansible-test.install
+++ /dev/null
@@ -1,2 +0,0 @@
-debian/tmp/usr/bin/ansible-test usr/bin
-debian/tmp/usr/lib/python3/dist-packages/ansible_test usr/lib/python3/dist-packages
diff --git a/packaging/debian/changelog b/packaging/debian/changelog
deleted file mode 100644
index 799f390e..00000000
--- a/packaging/debian/changelog
+++ /dev/null
@@ -1,5 +0,0 @@
-ansible-core (%VERSION%-%RELEASE%~%DIST%) %DIST%; urgency=low
-
- * %VERSION% release
-
- -- Ansible, Inc. <info@ansible.com> %DATE%
diff --git a/packaging/debian/compat b/packaging/debian/compat
deleted file mode 100644
index 7ed6ff82..00000000
--- a/packaging/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/packaging/debian/control b/packaging/debian/control
deleted file mode 100644
index ba724688..00000000
--- a/packaging/debian/control
+++ /dev/null
@@ -1,29 +0,0 @@
-Source: ansible-core
-Section: admin
-Priority: optional
-Standards-Version: 3.9.3
-Maintainer: Ansible, Inc. <info@ansible.com>
-Build-Depends: cdbs, debhelper (>= 5.0.0), python3-docutils, python3, dh-python | python-support, python3-setuptools, lsb-release, python3-straight.plugin, python3-packaging, python3-jinja2
-Homepage: https://github.com/ansible/ansible/
-
-Package: ansible-core
-Architecture: all
-Depends: python3-jinja2, python3-yaml, python3-paramiko, python3-cryptography, sshpass, ${misc:Depends}, ${python:Depends}
-Description: Ansible IT Automation
- Ansible is a radically simple model-driven configuration management,
- multi-node deployment, and remote task execution system. Ansible works
- over SSH and does not require any software or daemons to be installed
- on remote nodes. Extension modules can be written in any language and
- are transferred to managed machines automatically.
-
-Package: ansible-test
-Architecture: all
-Depends: ansible-core (= ${binary:Version}), python3-venv, ${misc:Depends}
-Description: Ansible IT Automation
- Ansible is a radically simple model-driven configuration management,
- multi-node deployment, and remote task execution system. Ansible works
- over SSH and does not require any software or daemons to be installed
- on remote nodes. Extension modules can be written in any language and
- are transferred to managed machines automatically.
- This package installs the ansible-test command for testing modules and
- plugins developed for ansible.
diff --git a/packaging/debian/copyright b/packaging/debian/copyright
deleted file mode 100644
index 4a17425f..00000000
--- a/packaging/debian/copyright
+++ /dev/null
@@ -1,26 +0,0 @@
-This package was debianized by Henry Graham (hzgraham) <Henry.Graham@mail.wvu.edu> on
-Tue, 17 Apr 2012 12:19:47 -0400.
-
-It was downloaded from https://github.com/ansible/ansible.git
-
-Copyright: Henry Graham (hzgraham) <Henry.Graham@mail.wvu.edu>
-
-License:
-
- This package is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; version 2 dated June, 1991.
-
- This package is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this package; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301,
- USA.
-
-On Debian systems, the complete text of the GNU General
-Public License can be found in `/usr/share/common-licenses/GPL'.
-
diff --git a/packaging/debian/docs b/packaging/debian/docs
deleted file mode 100644
index a1320b1b..00000000
--- a/packaging/debian/docs
+++ /dev/null
@@ -1 +0,0 @@
-README.rst
diff --git a/packaging/debian/pycompat b/packaging/debian/pycompat
deleted file mode 100644
index 0cfbf088..00000000
--- a/packaging/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/packaging/debian/rules b/packaging/debian/rules
deleted file mode 100755
index 2c0231c6..00000000
--- a/packaging/debian/rules
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/usr/bin/make -f
-# -- makefile --
-
-DEB_PYTHON3_MODULE_PACKAGES=ansible-core ansible_test
-#DEB_PYTHON_INSTALL_ARGS_ALL="--install-purelib=/usr/lib/python2.7/site-packages/"
-DEB_PYTHON_DISTUTILS_INSTALLDIR_SKEL = /usr/lib/python3/dist-packages/
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/python-distutils.mk
diff --git a/packaging/gentoo/README.md b/packaging/gentoo/README.md
deleted file mode 100644
index 991692c9..00000000
--- a/packaging/gentoo/README.md
+++ /dev/null
@@ -1,3 +0,0 @@
-Gentoo ebuilds are available in the main tree:
-
-emerge ansible
diff --git a/packaging/macports/.gitignore b/packaging/macports/.gitignore
deleted file mode 100644
index 2af97a6f..00000000
--- a/packaging/macports/.gitignore
+++ /dev/null
@@ -1,2 +0,0 @@
-PortIndex
-PortIndex.quick
diff --git a/packaging/macports/README.md b/packaging/macports/README.md
deleted file mode 100644
index 7984a96c..00000000
--- a/packaging/macports/README.md
+++ /dev/null
@@ -1,39 +0,0 @@
-This portfile installs ansible from the git repository, it will install the
-latest and greatest version of ansible. This portfile does not install the
-required dependencies to run in accelerated mode.
-
-## Installing the stable version of ansible via macports
-
-If you wish to run a stable version of ansible please do the following
-
-First update your macports repo to the latest versions
-
- $ sudo port sync
-
-Then install ansible
-
- $ sudo port install ansible
-
-## Installing the devel version of ansible via macports
-
-To use this Portfile to install the development version of ansible one should
-follow the instructions at
-<http://guide.macports.org/#development.local-repositories>
-
-The basic idea is to add the _ansible/packaging/macports_ directory to your
-_/opt/local/etc/macports/sources.conf_ file. You should have something similar
-to this at the end of the file
-
- file:///Users/jtang/develop/ansible/packaging/macports
- rsync://rsync.macports.org/release/tarballs/ports.tar [default]
-
-In the _ansible/packaging/macports_ directory, do this
-
- $ portindex
-
-Once the index is created the _Portfile_ will override the one in the upstream
-macports repository.
-
-Installing newer development versions should involve an uninstall, clean,
-install process or else the Portfile will need its version number/epoch
-bumped.
diff --git a/packaging/macports/sysutils/ansible/Portfile b/packaging/macports/sysutils/ansible/Portfile
deleted file mode 100644
index 9a386d77..00000000
--- a/packaging/macports/sysutils/ansible/Portfile
+++ /dev/null
@@ -1,67 +0,0 @@
-# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:ft=tcl:et:sw=4:ts=4:sts=4
-# $Id: Portfile 102428 2013-02-02 18:34:49Z blair@macports.org $
-
-PortSystem 1.0
-PortGroup python 1.0
-
-name ansible
-version devel
-categories sysutils
-supported_archs noarch
-
-maintainers nomaintainer
-
-homepage https://ansible.com/
-description Ansible IT Automation
-long_description \
- Ansible is a radically simple model-driven configuration \
- management, multi-node deployment, and orchestration \
- engine. Ansible works over SSH and does not require any software \
- or daemons to be installed on remote nodes. Extension modules can \
- be written in any language and are transferred to managed machines \
- automatically.
-
-license GPL-3+
-
-platforms darwin
-
-fetch.type git
-git.url https://github.com/ansible/ansible.git
-git.branch ${version}
-
-python.default_version 27
-depends_lib-append port:py${python.version}-jinja2 \
- port:py${python.version}-paramiko \
- port:py${python.version}-yaml
-
-patch {
- fs-traverse f ${worksrcpath} {
- if {[file isfile ${f}]} {
- reinplace -locale C "s#/etc/ansible#${prefix}/etc/ansible#g" ${f}
- reinplace -locale C "s#/usr/share/ansible#${prefix}/share/ansible#g" ${f}
- }
- }
-}
-
-post-destroot {
- # documentation and examples
- xinstall -m 644 -W ${worksrcpath} README.rst CHANGELOG.md CONTRIBUTING.md COPYING \
- ${destroot}${prefix}/share/doc/${name}
-
- xinstall -m 755 -d ${destroot}${prefix}/share/doc/examples
- xinstall -m 755 ${worksrcpath}/examples/ansible.cfg ${destroot}${prefix}/share/doc/${name}/examples
- xinstall -m 755 ${worksrcpath}/examples/hosts ${destroot}${prefix}/share/doc/${name}/examples
-
- file copy ${worksrcpath}/examples/playbooks ${destroot}${prefix}/share/doc/${name}/examples/
-
- # man pages
- xinstall -d 644 ${destroot}${prefix}/share/man/man1
- eval xinstall -m 755 [glob ${worksrcpath}/docs/man/man1/*.1] ${destroot}${prefix}/share/man/man1
-
- # install sample config and hosts file
- xinstall -m 755 -d ${destroot}${prefix}/etc/ansible
- xinstall -m 755 ${worksrcpath}/examples/ansible.cfg ${destroot}${prefix}/etc/ansible/ansible.cfg
- xinstall -m 755 ${worksrcpath}/examples/hosts ${destroot}${prefix}/etc/ansible/hosts
-}
-
-python.link_binaries_suffix