summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLee Garrett <lgarrett@rocketjump.eu>2022-11-29 01:46:40 +0100
committerLee Garrett <lgarrett@rocketjump.eu>2022-11-29 01:49:30 +0100
commit4e6c2136e6c28cc9910244a62a28ac5a8995c1dd (patch)
tree82e7933db766e518981dfd76a032c2099f3cd2da
parentff14d5d823543037f03244a27f9e242b2e5db29e (diff)
downloaddebian-ansible-core-4e6c2136e6c28cc9910244a62a28ac5a8995c1dd.zip
Tighten resolvelib dependency (Closes: #1010345)
-rw-r--r--debian/control3
-rw-r--r--debian/patches/0009-resolvelib_0_9_0_compat.patch92
-rw-r--r--debian/patches/series1
3 files changed, 95 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index e40682b8..7133d425 100644
--- a/debian/control
+++ b/debian/control
@@ -12,7 +12,8 @@ Build-Depends: debhelper-compat (= 13),
python3-jinja2 (>= 3.0.0~),
python3-packaging,
# python3-pygments <!nodoc>,
- python3-resolvelib,
+ python3-resolvelib (>= 0.5.3~),
+ python3-resolvelib (<< 0.10),
# python3-rstcheck <!nodoc>,
python3-setuptools,
python3-straight.plugin,
diff --git a/debian/patches/0009-resolvelib_0_9_0_compat.patch b/debian/patches/0009-resolvelib_0_9_0_compat.patch
new file mode 100644
index 00000000..24fc4787
--- /dev/null
+++ b/debian/patches/0009-resolvelib_0_9_0_compat.patch
@@ -0,0 +1,92 @@
+Description: ansible-galaxy - support resolvelib >= 0.5.3, < 0.10.0
+Author: Wong Hoi Sing Edison <hswong3i@gmail.com>
+Origin: upstream, https://github.com/ansible/ansible/pull/79399
+Applied-Upstream: yes
+Reviewed-by: Lee Garrett <debian@rocketjump.eu>
+Last-Update: 2022-11-29
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- /dev/null
++++ b/changelogs/fragments/79399-resolvelib_lt_0_10_0.yml
+@@ -0,0 +1,2 @@
++minor_changes:
++ - ansible-galaxy - support ``resolvelib >= 0.5.3, < 0.10.0``.
+--- a/lib/ansible/galaxy/dependency_resolution/providers.py
++++ b/lib/ansible/galaxy/dependency_resolution/providers.py
+@@ -42,7 +42,7 @@
+
+ # TODO: add python requirements to ansible-test's ansible-core distribution info and remove the hardcoded lowerbound/upperbound fallback
+ RESOLVELIB_LOWERBOUND = SemanticVersion("0.5.3")
+-RESOLVELIB_UPPERBOUND = SemanticVersion("0.9.0")
++RESOLVELIB_UPPERBOUND = SemanticVersion("0.10.0")
+ RESOLVELIB_VERSION = SemanticVersion.from_loose_version(LooseVersion(resolvelib_version))
+
+
+@@ -220,7 +220,7 @@
+ Mapping of identifier, list of named tuple pairs.
+ The named tuples have the entries ``requirement`` and ``parent``.
+
+- resolvelib >=0.8.0, <= 0.8.1
++ resolvelib >=0.8.0, <= 0.9.0
+
+ :param identifier: The value returned by ``identify()``.
+
+--- a/requirements.txt
++++ b/requirements.txt
+@@ -12,4 +12,4 @@
+ # NOTE: Ref: https://github.com/sarugaku/resolvelib/issues/69
+ # NOTE: When updating the upper bound, also update the latest version used
+ # NOTE: in the ansible-galaxy-collection test suite.
+-resolvelib >= 0.5.3, < 0.9.0 # dependency resolver used by ansible-galaxy
++resolvelib >= 0.5.3, < 0.10.0 # dependency resolver used by ansible-galaxy
+--- a/test/lib/ansible_test/_data/requirements/ansible.txt
++++ b/test/lib/ansible_test/_data/requirements/ansible.txt
+@@ -12,4 +12,4 @@
+ # NOTE: Ref: https://github.com/sarugaku/resolvelib/issues/69
+ # NOTE: When updating the upper bound, also update the latest version used
+ # NOTE: in the ansible-galaxy-collection test suite.
+-resolvelib >= 0.5.3, < 0.9.0 # dependency resolver used by ansible-galaxy
++resolvelib >= 0.5.3, < 0.10.0 # dependency resolver used by ansible-galaxy
+--- a/test/sanity/code-smell/docs-build.requirements.in
++++ b/test/sanity/code-smell/docs-build.requirements.in
+@@ -1,6 +1,6 @@
+ jinja2
+ pyyaml
+-resolvelib < 0.9.0
++resolvelib < 0.10.0
+ sphinx == 4.2.0
+ sphinx-notfound-page
+ sphinx-ansible-theme
+--- a/test/sanity/code-smell/docs-build.requirements.txt
++++ b/test/sanity/code-smell/docs-build.requirements.txt
+@@ -27,7 +27,7 @@
+ pytz==2022.2.1
+ PyYAML==6.0
+ requests==2.28.1
+-resolvelib==0.8.1
++resolvelib==0.9.0
+ rstcheck==3.5.0
+ semantic-version==2.10.0
+ sh==1.14.3
+--- a/test/sanity/code-smell/package-data.requirements.in
++++ b/test/sanity/code-smell/package-data.requirements.in
+@@ -1,7 +1,7 @@
+ docutils < 0.18 # match version required by sphinx in the docs-build sanity test
+ jinja2
+ pyyaml # ansible-core requirement
+-resolvelib < 0.9.0
++resolvelib < 0.10.0
+ rstcheck < 4 # match version used in other sanity tests
+ straight.plugin
+ antsibull-changelog
+--- a/test/sanity/code-smell/package-data.requirements.txt
++++ b/test/sanity/code-smell/package-data.requirements.txt
+@@ -6,7 +6,7 @@
+ packaging==21.3
+ pyparsing==3.0.9
+ PyYAML==6.0
+-resolvelib==0.8.1
++resolvelib==0.9.0
+ rstcheck==3.5.0
+ semantic-version==2.10.0
+ straight.plugin==1.5.0
diff --git a/debian/patches/series b/debian/patches/series
index 66bfa3f5..465c3dc5 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
0005-use-py3.patch
+0009-resolvelib_0_9_0_compat.patch